RFR: 8199318: add idempotent copy operation for Map.Entry [v2]
Stuart Marks
smarks at openjdk.java.net
Wed Jun 2 23:19:37 UTC 2021
On Wed, 2 Jun 2021 18:07:55 GMT, Daniel Fuchs <dfuchs at openjdk.org> wrote:
>> Stuart Marks has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Tiny editorial tweaks.
>
> src/java.base/share/classes/java/util/Map.java line 396:
>
>> 394:
>> 395: /**
>> 396: * A map entry (key-value pair). The Entry may be unmodifiable, or the
>
> In that case then maybe it should be `{@code Entry}` in both places where `entry` was replaced with `Entry` ?
Maybe. We're not terribly consistent about this. A fair amount of the docs just uses a plain-text, capitalized form of a class name, as opposed to the code font. Using the code font everywhere adds clutter to both the markup and to the rendered output. In this case I wanted to distinguish the generic mention of an entry in a map from an instance of an Entry object. In cases where it needs to be absolutely clear, I used `Map.Entry` (the qualified name, in code font). Doing that here seems like it would add too much clutter though.
-------------
PR: https://git.openjdk.java.net/jdk/pull/4295
More information about the core-libs-dev
mailing list