RFR: 8268469: Update java.time to use switch expressions [v3]
Chris Hegarty
chegar at openjdk.java.net
Wed Jun 16 11:14:40 UTC 2021
On Wed, 16 Jun 2021 10:59:59 GMT, Stephen Colebourne <scolebourne at openjdk.org> wrote:
>> Patrick Concannon has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains four additional commits since the last revision:
>>
>> - 8268469: Removed excessive spacing; corrected misplaced comments
>> - Merge remote-tracking branch 'origin/master' into JDK-8268469
>> - Merge remote-tracking branch 'origin/master' into JDK-8268469
>> - 8268469: Update java.time to use switch expressions
>
> src/java.base/share/classes/java/time/Month.java line 480:
>
>> 478: int leap = leapYear ? 1 : 0;
>> 479: return switch (this) {
>> 480: case JANUARY -> 1;
>
> Unnecessary alignment
The vertical alignment improves readability in these short-line cases. Removing the spaces before the arrows will make it a little harder to discern the difference between the cases.
-------------
PR: https://git.openjdk.java.net/jdk/pull/4433
More information about the core-libs-dev
mailing list