Withdrawn: 5023614: UUID needs methods to get most/leastSigBits and write to DataOutput
Richard Fussenegger
github.com+1059453+fleshgrinder at openjdk.java.net
Thu Jun 17 06:16:19 UTC 2021
On Thu, 26 Nov 2020 18:24:22 GMT, Richard Fussenegger <github.com+1059453+Fleshgrinder at openjdk.org> wrote:
> Made byte constructor public and changed the length assertion to an `IllegalArgumentException`, added a `getBytes` method that allows users to retrieve the raw bytes of the UUID, and created a new private constructor with an optimized construction for byte arrays that can set the version as desired and the variant to RFC 4122. Also changed the existing static factory methods to use the new constructor and removed the duplicate code from them where the variant and version is being set.
>
> Report [5023614](https://bugs.java.com/bugdatabase/view_bug.do?bug_id=5023614) asks for more than what I provided and with different names. However, I believe that there is no value in providing methods to deal with `DataInput` and `DataOutput` because they would only encapsulate single method calls that the caller can directly write as well (e.g. `output.write(uuid.getBytes())` vs `uuid.write(output)`). Hence, I consider this change to satisfy the feature request.
This pull request has been closed without being integrated.
-------------
PR: https://git.openjdk.java.net/jdk/pull/1465
More information about the core-libs-dev
mailing list