RFR: 8186958: Need method to create pre-sized HashMap [v12]
Alan Bateman
alanb at openjdk.java.net
Sun Apr 10 07:44:33 UTC 2022
On Wed, 6 Apr 2022 16:02:31 GMT, XenoAmess <duke at openjdk.java.net> wrote:
>> 8186958: Need method to create pre-sized HashMap
>
> XenoAmess has updated the pull request incrementally with one additional commit since the last revision:
>
> use (double) DEFAULT_LOAD_FACTOR instead of 0.75
src/java.base/share/classes/java/lang/module/Resolver.java line 501:
> 499: private Map<ResolvedModule, Set<ResolvedModule>> makeGraph(Configuration cf) {
> 500:
> 501: int nameToReferenceSize = nameToReference.size();
This can be renamed moduleCount to make it easier to read.
-------------
PR: https://git.openjdk.java.net/jdk/pull/7928
More information about the core-libs-dev
mailing list