RFR: 8283667: [vectorapi] Vectorization for masked load with IOOBE with predicate feature [v2]
Xiaohong Gong
xgong at openjdk.java.net
Fri Apr 22 07:12:28 UTC 2022
On Wed, 20 Apr 2022 02:46:09 GMT, Xiaohong Gong <xgong at openjdk.org> wrote:
>> src/jdk.incubator.vector/share/classes/jdk/incubator/vector/ByteVector.java line 2861:
>>
>>> 2859: ByteSpecies vsp = (ByteSpecies) species;
>>> 2860: if (offset >= 0 && offset <= (a.length - species.vectorByteSize())) {
>>> 2861: return vsp.dummyVector().fromByteArray0(a, offset, m, /* usePred */ false).maybeSwap(bo);
>>
>> Instead of usePred a term like inRange or offetInRage or offsetInVectorRange would be easier to follow.
>
> Thanks for the review. I will change it later.
The name is updated to `offsetInRange`. Thanks!
-------------
PR: https://git.openjdk.java.net/jdk/pull/8035
More information about the core-libs-dev
mailing list