RFR: 8294989: ResourceBundle naming convention issue in JdbcRowSetResourceBundle.java [v11]
Brent Christian
bchristi at openjdk.org
Fri Oct 21 22:14:52 UTC 2022
On Fri, 21 Oct 2022 19:55:55 GMT, Justin Lu <duke at openjdk.org> wrote:
>> Issue: Resource bundle name does not follow proper naming conventions according to [getBundle method](https://docs.oracle.com/en/java/javase/18/docs/api/java.base/java/util/ResourceBundle.html#getBundle(java.lang.String,java.util.Locale,java.lang.Module)) for base name parameter
>>
>> Fix: Modified bundle name to be a fully qualified class and added regression tests.
>
> Justin Lu has updated the pull request incrementally with one additional commit since the last revision:
>
> white space
test/jdk/javax/sql/resourceBundleTests/ValidateGetBundle.java line 49:
> 47: // The resource bundle will not be found when the path is specified
> 48: testResourceBundleAccess(PATH_TO_BUNDLE, false);
> 49: }
It seems to me this could be reworked into a `DataProvider` for `testResourceBundleAccess()`.
-------------
PR: https://git.openjdk.org/jdk/pull/10612
More information about the core-libs-dev
mailing list