RFR: 8305425: Thread.isAlive0 doesn't need to call into the VM [v2]

Aleksey Shipilev shade at openjdk.org
Mon Apr 3 14:01:01 UTC 2023


On Mon, 3 Apr 2023 12:32:35 GMT, David Holmes <dholmes at openjdk.org> wrote:

> > This looks interesting. I think it is time to rename eetop to javaThreadAddr ...
> 
> Feel free to file a RFE but not as part of this PR. :)

Well, when this thing is considered in isolation, it changes the clear `isAlive0()` call to rather obscure `eetop != 0` condition, with no documentation what that field actually is. At very least we should add the comment that the field carries the native thread pointer, and `!= 0` is actually checking for `null`.

But, someone (who should remain anonymous under the alias, say... rolls dice... Andrei?) pointed out that async-profiler looks up `eetop`, so the rename would break the profiler until the renamed field is handled there. So the rename at this point is a bit dicey: https://github.com/async-profiler/async-profiler/blob/39b0bdb5e446b1b88acdf37fd18a4560f5176a2e/src/vmStructs.cpp#L409

-------------

PR Comment: https://git.openjdk.org/jdk/pull/13287#issuecomment-1494370793


More information about the core-libs-dev mailing list