RFR: 8303866: Allow ZipInputStream.readEnd to parse small Zip64 ZIP files [v8]

Eirik Bjorsnos duke at openjdk.org
Fri Dec 1 18:54:35 UTC 2023


On Wed, 15 Nov 2023 20:10:53 GMT, Eirik Bjorsnos <duke at openjdk.org> wrote:

>> ZipInputStream.readEnd currently assumes a Zip64 data descriptor if the number of compressed or uncompressed bytes read from the inflater is larger than the Zip64 magic value.
>> 
>> While the ZIP format  mandates that the data descriptor `SHOULD be stored in ZIP64 format (as 8 byte values) when a file's size exceeds 0xFFFFFFFF`, it also states that `ZIP64 format MAY be used regardless of the size of a file`. For such small entries, the above assumption does not hold.
>> 
>> This PR augments ZipInputStream.readEnd to also assume 8-byte sizes if the ZipEntry includes a Zip64 extra information field. This brings ZipInputStream into alignment with the APPNOTE format spec:
>> 
>> 
>> When extracting, if the zip64 extended information extra 
>> field is present for the file the compressed and 
>> uncompressed sizes will be 8 byte values.
>> 
>> 
>> While small Zip64 files with 8-byte data descriptors are not commonly found in the wild, it is possible to create one using the Info-ZIP command line `-fd` flag:
>> 
>> `echo hello | zip -fd > hello.zip`
>> 
>> The PR also adds a test verifying that such a small Zip64 file can be parsed by ZipInputStream.
>
> Eirik Bjorsnos has updated the pull request incrementally with one additional commit since the last revision:
> 
>   Extract ZIP64_BLOCK_SIZE_OFFSET as a constant

Thanks for your patient and thorough review of this long-lived PR, Lance!

No worries, we can hold off the integration until after 22 is forked off mainline.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/12524#issuecomment-1830464397


More information about the core-libs-dev mailing list