RFR: 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder [v2]
Stefan Karlsson
stefank at openjdk.org
Mon Dec 11 14:03:36 UTC 2023
> [JDK-8315097](https://bugs.openjdk.org/browse/JDK-8315097): 'Rename createJavaProcessBuilder' changed the name of the ProcessTools helper functions used to create `ProcessBuilder`s used to spawn new java test processes.
>
> We now have `createTestJavaProcessBuilder` and `createLimitedTestJavaProcess`. The former prepends jvm options from jtreg, while the latter doesn't.
>
> With these functions it is common to see the following pattern in tests:
>
> ProcessBuilder pb = ProcessTools.createTestJavaProcessBuilder(...);
> OutputAnalyzer output = executeProcess(pb);
>
>
> We have a couple of thin wrapper in `ProcessTools` that does exactly this, so that the code can be written as a one-liner:
>
> OutputAnalyzer output = ProcessTools.executeTestJvm();
>
>
> I propose that we name this functions using the same naming scheme we used for `createTestJavaProcessBuilder` and `createLimitedTestJavaProcessBuilder`. That is, we change `executeTestJvm` to `executeTestJava` and add a new `executeLimitedTestJava` function.
Stefan Karlsson has updated the pull request incrementally with one additional commit since the last revision:
Fix impl and add test
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/17049/files
- new: https://git.openjdk.org/jdk/pull/17049/files/080caef5..ad072e06
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=17049&range=01
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=17049&range=00-01
Stats: 54 lines in 2 files changed: 52 ins; 0 del; 2 mod
Patch: https://git.openjdk.org/jdk/pull/17049.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/17049/head:pull/17049
PR: https://git.openjdk.org/jdk/pull/17049
More information about the core-libs-dev
mailing list