RFR: 8310994: Add JFR event for selection operations [v2]

Tim Prinzing tprinzing at openjdk.org
Wed Dec 13 19:01:49 UTC 2023


On Wed, 13 Dec 2023 18:47:50 GMT, Daniel Fuchs <dfuchs at openjdk.org> wrote:

>> Tim Prinzing has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains 12 additional commits since the last revision:
>> 
>>  - Change event generation:
>>    
>>    - selectNow is filtered out
>>    - select that times out is always sent
>>    - select without timeout uses duration test
>>  - rename event to SelectorSelect, field to selectionKeyCount.
>>  - Merge branch 'master' into JDK-8310994
>>  - remove trailing whitespace
>>  - event logic outside of the lock, selector in try block
>>  - remove unused import
>>  - fix TestConfigure failure
>>  - add event defaults
>>  - Merge branch 'master' into JDK-8310994
>>  - minor test cleanup
>>  - ... and 2 more: https://git.openjdk.org/jdk/compare/f9910028...2f7dafd8
>
> src/java.base/share/classes/jdk/internal/event/SelectorSelectEvent.java line 41:
> 
>> 39: public class SelectorSelectEvent extends Event {
>> 40: 
>> 41:     public int selectionKeyCount;
> 
> I still believe we should record the timeout parameter in the event.

Good point about the wakeup.  I'll add the field.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/16710#discussion_r1425765145


More information about the core-libs-dev mailing list