RFR: 8297632: InputStream.transferTo() method should specify what the return value should be when the number of bytes transfered is larger than Long.MAX_VALUE [v6]

Brian Burkhalter bpb at openjdk.org
Fri Feb 10 17:38:55 UTC 2023


On Fri, 10 Feb 2023 13:25:29 GMT, Alan Bateman <alanb at openjdk.org> wrote:

>> Brian Burkhalter has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   8297632: Increment recent copyright year to 2023
>
> src/java.base/share/classes/java/io/SequenceInputStream.java line 249:
> 
>> 247:                 } catch (ArithmeticException ignore) {
>> 248:                     return Long.MAX_VALUE;
>> 249:                 }
> 
> This one could check if c < Long.MAX_VALUE like the other implementations, if only for consistency. c could be renamed to transferred too.

So changed in 6bdf3220c70e120e8dad552e177dc80f34495c73.

-------------

PR: https://git.openjdk.org/jdk/pull/11403


More information about the core-libs-dev mailing list