RFR: 8310890: Normalize identifier names
Roger Riggs
rriggs at openjdk.org
Mon Jun 26 18:25:03 UTC 2023
On Mon, 26 Jun 2023 14:07:03 GMT, Pavel Rappo <prappo at openjdk.org> wrote:
> Please review this cleanup PR to normalize names of identifiers which are Java variables/fields or tokens in text files. Those names either contain a pronoun that is very rarely used in code, or seem like they contain such a pronoun, which, in fact, they don't. Either way, the goal is to improve readability and clarity.
>
> Also, this PR fixes a few related typos.
Looks good, with or without the suggestion.
src/java.base/share/classes/java/util/EnumMap.java line 690:
> 688: Object otherValue = em.vals[i];
> 689: if (otherValue != ourValue &&
> 690: (otherValue == null || !otherValue.equals(ourValue)))
Is this the same as java.util.Objects:
`!Objects.equals(vals[i], em.vals[i]);`
-------------
Marked as reviewed by rriggs (Reviewer).
PR Review: https://git.openjdk.org/jdk/pull/14653#pullrequestreview-1499137712
PR Review Comment: https://git.openjdk.org/jdk/pull/14653#discussion_r1242585695
More information about the core-libs-dev
mailing list