RFR: 8308960: Decouple internal Version and OperatingSystem classes
Daniel Fuchs
dfuchs at openjdk.org
Fri May 26 15:24:55 UTC 2023
On Fri, 26 May 2023 14:57:21 GMT, Roger Riggs <rriggs at openjdk.org> wrote:
> Decouple the jdk.internal.util OperatingSystem and Version classes to simplify class loading and avoid an indirect cyclic initialization.
>
> Move the method to get the current OS version from OperatingSystem to the Version class and its initialization.
> Revert to using String.toUpperCase() instead of custom code to uppercase.
>
> Update the uses of OperatingSystem.version to be Version.current.
Should we take this opportunity to rename `jdk.internal.util.Version` into something like `OsVersion` to make it more clear what its `current()` method actually returns?
-------------
PR Comment: https://git.openjdk.org/jdk/pull/14181#issuecomment-1564553174
More information about the core-libs-dev
mailing list