RFR: 8319220: Pattern matching switch with a lot of cases is unduly slow
Rémi Forax
forax at openjdk.org
Fri Nov 3 14:23:05 UTC 2023
On Fri, 3 Nov 2023 08:41:12 GMT, Jan Lahoda <jlahoda at openjdk.org> wrote:
> Consider code like:
>
> void test(Object o) {
> switch (o) {
> case X1 -> {}
> case X2 -> {}
> ...(about 100 cases)
> ```
>
> javac will compile the switch into a switch whose selector is an indy invocation to `SwitchBootstraps.typeSwitch`, with static arguments being the types in the cases.
>
> `SwitchBootstraps.typeSwitch` will then create a chain of `MethodHandle`s performing `instanceof` checks between the switch's selector and the given case type. The problem is that when the number of cases is high enough, (more than ~40-50), the chain gets too long, and the tests won't inline anymore. This then leads to a very bad performance, when compared to manually written if-instanceof-else-if-instanceof- chain.
>
> The proposal herein is to use bytecode (written using the ClassFile API/library) instead of the `MethodHandle`s chain. The overall performance of this seems to be similar to the manually written if-instanceof-else-if-instanceof- chain.
>
> Using the benchmark from the bug, and this patch, I am getting:
>
> MyBenchmark.testIfElse100 thrpt 5 521826.326 ± 7510.042 ops/s
> MyBenchmark.testSwitch100 thrpt 5 505440.170 ± 3757.178 ops/s
>
>
> The most tricky part of this new way to generate the tests is handling of non-type case labels, and in particular cases with enum constant labels. The resolution of enum constants is deferred as much as possible, by using an indirection through the `ResolvedEnumLabels`.
>
> Further improvements may be possible, esp. for some specific cases (like all cases having a type, and the type being a final class).
src/java.base/share/classes/java/lang/runtime/SwitchBootstraps.java line 397:
> 395: cb.iload(1);
> 396: Label dflt = cb.newLabel();
> 397: record Element(Label target, Label next, Object label) {}
'label' is not a Label, is there a better name to make the difference between the switch label and the bytecode label
src/java.base/share/classes/java/lang/runtime/SwitchBootstraps.java line 423:
> 421: Label next = element.next();
> 422: cb.labelBinding(element.target());
> 423: if (element.label() instanceof Class<?> classLabel) {
It's too bad we can not use a switch on the label here instead of a bunch of instanceof :)
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/16489#discussion_r1381754699
PR Review Comment: https://git.openjdk.org/jdk/pull/16489#discussion_r1381756247
More information about the core-libs-dev
mailing list