RFR: 8303866: Allow ZipInputStream.readEnd to parse small Zip64 ZIP files [v7]
Eirik Bjorsnos
duke at openjdk.org
Wed Nov 15 20:02:46 UTC 2023
> ZipInputStream.readEnd currently assumes a Zip64 data descriptor if the number of compressed or uncompressed bytes read from the inflater is larger than the Zip64 magic value.
>
> While the ZIP format mandates that the data descriptor `SHOULD be stored in ZIP64 format (as 8 byte values) when a file's size exceeds 0xFFFFFFFF`, it also states that `ZIP64 format MAY be used regardless of the size of a file`. For such small entries, the above assumption does not hold.
>
> This PR augments ZipInputStream.readEnd to also assume 8-byte sizes if the ZipEntry includes a Zip64 extra information field. This brings ZipInputStream into alignment with the APPNOTE format spec:
>
>
> When extracting, if the zip64 extended information extra
> field is present for the file the compressed and
> uncompressed sizes will be 8 byte values.
>
>
> While small Zip64 files with 8-byte data descriptors are not commonly found in the wild, it is possible to create one using the Info-ZIP command line `-fd` flag:
>
> `echo hello | zip -fd > hello.zip`
>
> The PR also adds a test verifying that such a small Zip64 file can be parsed by ZipInputStream.
Eirik Bjorsnos has updated the pull request incrementally with three additional commits since the last revision:
- A Zip64 extra field used in a LOC header must include both the uncompressed and compressed size fields, and does not include local header offset or disk start number fields. Conequently, a valid LOC Zip64 block must always be 16 bytes long.
- Document better the zip command and options used to generate the test vector ZIP
- Fix spelling of "presence"
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/12524/files
- new: https://git.openjdk.org/jdk/pull/12524/files/7601b8dd..a77147bc
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=12524&range=06
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=12524&range=05-06
Stats: 15 lines in 2 files changed: 8 ins; 2 del; 5 mod
Patch: https://git.openjdk.org/jdk/pull/12524.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/12524/head:pull/12524
PR: https://git.openjdk.org/jdk/pull/12524
More information about the core-libs-dev
mailing list