RFR: 8315960: test/jdk/java/io/File/TempDirDoesNotExist.java leaves test files behind [v5]

Roger Riggs rriggs at openjdk.org
Tue Sep 19 21:19:44 UTC 2023


On Tue, 19 Sep 2023 20:53:44 GMT, Brian Burkhalter <bpb at openjdk.org> wrote:

>> Add a `finally` block to delete the created files.
>
> Brian Burkhalter has updated the pull request incrementally with one additional commit since the last revision:
> 
>   8315960: Improve test as suggested by Reviewer

test/jdk/java/io/File/TempDirDoesNotExist.java line 118:

> 116:     }
> 117: 
> 118:     public static Stream<Arguments> nonexistentProvider() {

The `nonexistentProvider` seems like an odd name. The only provider here is the junit provider (not a FileSystem provider)
How about `NoTempDir` and `TempDir` for the two argument streams.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/15757#discussion_r1330708013


More information about the core-libs-dev mailing list