RFR: 8343962: [REDO] Move getChars to DecimalDigits [v2]

Shaojin Wen swen at openjdk.org
Fri Dec 6 18:10:29 UTC 2024


> This PR is a resubmission after PR #21593 was rolled back, and the unsafe offset overflow issue has been fixed.
> 
> 1) Move getChars methods of StringLatin1 and StringUTF16 to DecimalDigits to reduce duplication.
> 
> 2) HexDigits and OctalDigits also include getCharsLatin1 and getCharsUTF16
> 
> 3) Putting these two methods into DecimalDigits can avoid the need to expose them in JavaLangAccess
> Eliminate duplicate code in BigDecimal
> 
> 4) This PR will improve the performance of Integer/Long.toString and StringBuilder.append(int/long) scenarios. This is because Unsafe.putByte is used to eliminate array bounds checks, and of course this elimination is safe. In previous versions, in Integer/Long.toString and StringBuilder.append(int/long) scenarios, -COMPACT_STRING performed better than +COMPACT_STRING. This is because StringUTF16.getChars uses StringUTF16.putChar, which is similar to Unsafe.putChar, and there is no bounds check.

Shaojin Wen has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains 15 additional commits since the last revision:

 - Merge remote-tracking branch 'upstream/master' into int_get_chars_dedup_202411
 - fix unsafe address overflow
 - add benchmark
 - remove comments, from @liach
 - Merge remote-tracking branch 'upstream/master' into int_get_chars_dedup_202410
 - fix Helper
 - fix Helper
 - fix Helper
 - unsafe putByte
 - remove digitPair
 - ... and 5 more: https://git.openjdk.org/jdk/compare/eb49b966...ee05a6f5

-------------

Changes:
  - all: https://git.openjdk.org/jdk/pull/22023/files
  - new: https://git.openjdk.org/jdk/pull/22023/files/cd9ba309..ee05a6f5

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=jdk&pr=22023&range=01
 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=22023&range=00-01

  Stats: 330794 lines in 5998 files changed: 165380 ins; 141109 del; 24305 mod
  Patch: https://git.openjdk.org/jdk/pull/22023.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/22023/head:pull/22023

PR: https://git.openjdk.org/jdk/pull/22023


More information about the core-libs-dev mailing list