RFR: 8321274: Rename ZipEntry.extraAttributes to ZipEntry.externalAttributes [v2]

Eirik Bjørsnøs eirbjo at openjdk.org
Sat Feb 3 17:31:00 UTC 2024


On Fri, 2 Feb 2024 20:43:54 GMT, Lance Andersen <lancea at openjdk.org> wrote:

> I think the proposed change above makes things clearer. Perhaps also make the same change in zipfs as well while you are at it?

I have pushed the rename to "ZipEntry.externalFileAttributes". Also renamed `ZipFileSystem.Entry.posixPerms` to `ZipFileSystem.Entry.externalFileAttributes`. Hopefully this makes things clearer.

A side note: The Posix support in `ZipFileSystem` is somewhat odd in that it supports the notion of a `null` permission set. So setting the permissions attribute to `null` clears all the attributes, not just the permisson ones.  But even so, I think using the full name here is also an improvement, since it signals that the field may also carry preexisting file type, setuid, setgid, sticky bits.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/16952#issuecomment-1925403883


More information about the core-libs-dev mailing list