Integrated: 8303866: Allow ZipInputStream.readEnd to parse small Zip64 ZIP files
Eirik Bjørsnøs
eirbjo at openjdk.org
Tue Feb 13 16:30:19 UTC 2024
On Sun, 12 Feb 2023 15:41:55 GMT, Eirik Bjørsnøs <eirbjo at openjdk.org> wrote:
> ZipInputStream.readEnd currently assumes a Zip64 data descriptor if the number of compressed or uncompressed bytes read from the inflater is larger than the Zip64 magic value.
>
> While the ZIP format mandates that the data descriptor `SHOULD be stored in ZIP64 format (as 8 byte values) when a file's size exceeds 0xFFFFFFFF`, it also states that `ZIP64 format MAY be used regardless of the size of a file`. For such small entries, the above assumption does not hold.
>
> This PR augments ZipInputStream.readEnd to also assume 8-byte sizes if the ZipEntry includes a Zip64 extra information field AND at least one of the 'compressed size' and 'uncompressed size' have the expected Zip64 "magic" value 0xFFFFFFFF. This brings ZipInputStream into alignment with the APPNOTE format spec:
>
>
> When extracting, if the zip64 extended information extra
> field is present for the file the compressed and
> uncompressed sizes will be 8 byte values.
>
>
> While small Zip64 files with 8-byte data descriptors are not commonly found in the wild, it is possible to create one using the Info-ZIP command line `-fd` flag:
>
> `echo hello | zip -fd > hello.zip`
>
> The PR also adds a test verifying that such a small Zip64 file can be parsed by ZipInputStream.
This pull request has now been integrated.
Changeset: 628cd8a4
Author: Eirik Bjørsnøs <eirbjo at openjdk.org>
URL: https://git.openjdk.org/jdk/commit/628cd8a489fd54db18204c3bbaf4339d7ab5e9d6
Stats: 341 lines in 2 files changed: 338 ins; 0 del; 3 mod
8303866: Allow ZipInputStream.readEnd to parse small Zip64 ZIP files
Reviewed-by: lancea, jpai
-------------
PR: https://git.openjdk.org/jdk/pull/12524
More information about the core-libs-dev
mailing list