RFR: 8324799: Use correct extension for C++ test headers
Kim Barrett
kbarrett at openjdk.org
Wed Feb 28 01:24:41 UTC 2024
Please review this change that renames some test .h files to .hpp. These
files contain C++ code and should be named accordingly. Some of them contain
uses of NULL, which we change to nullptr.
The renamed files are:
test/hotspot/jtreg/vmTestbase/nsk/share/aod/aod.h
test/hotspot/jtreg/vmTestbase/nsk/share/jni/jni_tools.h
test/hotspot/jtreg/vmTestbase/nsk/share/jvmti/jvmti_tools.h
test/hotspot/jtreg/vmTestbase/nsk/share/jvmti/JVMTITools.h
test/hotspot/jtreg/vmTestbase/nsk/share/native/nsk_tools.h
test/lib/jdk/test/lib/jvmti/jvmti_thread.h
test/lib/jdk/test/lib/jvmti/jvmti_common.h
test/lib/native/testlib_threads.h
The #include updates were performed mostly mechanically, and builds would fail
if there were mistakes. The exception is test
test/hotspot/jtreg/serviceability/jvmti/FollowReferences/FieldIndices/libFieldIndicesTest.cpp,
which was added after I'd done the mechanical update, so was updated by hand.
The copyright updates were similarly performed mechanically. All but a handful
of the including files have already had their copyrights updated recently,
likely as part of JDK-8324681.
Thus, the only "interesting" changes are to the renamed files.
Testing: mach5 tier1
-------------
Commit messages:
- update new test
- update copyrights
- fix jvmti README
- rename NULLs in jvmti_common.hpp
- rename jvmti_common.h
- rename NULLs in jvmti_thread.hpp
- rename jvmti_thread.h
- rename NULLs in testlib_threads.hpp
- rename testlib_threads.h -- no copyright
- rename nsk_tools.h -- no copyright
- ... and 5 more: https://git.openjdk.org/jdk/compare/16d917a8...4154005e
Changes: https://git.openjdk.org/jdk/pull/18035/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=18035&range=00
Issue: https://bugs.openjdk.org/browse/JDK-8324799
Stats: 1535 lines in 731 files changed: 133 ins; 133 del; 1269 mod
Patch: https://git.openjdk.org/jdk/pull/18035.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/18035/head:pull/18035
PR: https://git.openjdk.org/jdk/pull/18035
More information about the core-libs-dev
mailing list