RFR: 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder [v4]
Stefan Karlsson
stefank at openjdk.org
Tue Jan 2 15:36:07 UTC 2024
> [JDK-8315097](https://bugs.openjdk.org/browse/JDK-8315097): 'Rename createJavaProcessBuilder' changed the name of the ProcessTools helper functions used to create `ProcessBuilder`s used to spawn new java test processes.
>
> We now have `createTestJavaProcessBuilder` and `createLimitedTestJavaProcess`. The former prepends jvm options from jtreg, while the latter doesn't.
>
> With these functions it is common to see the following pattern in tests:
>
> ProcessBuilder pb = ProcessTools.createTestJavaProcessBuilder(...);
> OutputAnalyzer output = executeProcess(pb);
>
>
> We have a couple of thin wrapper in `ProcessTools` that does exactly this, so that the code can be written as a one-liner:
>
> OutputAnalyzer output = ProcessTools.executeTestJvm();
>
>
> I propose that we name this functions using the same naming scheme we used for `createTestJavaProcessBuilder` and `createLimitedTestJavaProcessBuilder`. That is, we change `executeTestJvm` to `executeTestJava` and add a new `executeLimitedTestJava` function.
Stefan Karlsson has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains four additional commits since the last revision:
- Merge remote-tracking branch 'upstream/master' into rename_executeTestJvm
- Test cleanup
- Fix impl and add test
- 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/17049/files
- new: https://git.openjdk.org/jdk/pull/17049/files/5d488f42..486dc6d5
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=17049&range=03
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=17049&range=02-03
Stats: 5249 lines in 348 files changed: 3069 ins; 973 del; 1207 mod
Patch: https://git.openjdk.org/jdk/pull/17049.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/17049/head:pull/17049
PR: https://git.openjdk.org/jdk/pull/17049
More information about the core-libs-dev
mailing list