RFR: 8303866: Allow ZipInputStream.readEnd to parse small Zip64 ZIP files [v12]
Andrey Turbanov
aturbanov at openjdk.org
Tue Jan 16 07:01:27 UTC 2024
On Wed, 10 Jan 2024 13:39:52 GMT, Eirik Bjørsnøs <eirbjo at openjdk.org> wrote:
>> ZipInputStream.readEnd currently assumes a Zip64 data descriptor if the number of compressed or uncompressed bytes read from the inflater is larger than the Zip64 magic value.
>>
>> While the ZIP format mandates that the data descriptor `SHOULD be stored in ZIP64 format (as 8 byte values) when a file's size exceeds 0xFFFFFFFF`, it also states that `ZIP64 format MAY be used regardless of the size of a file`. For such small entries, the above assumption does not hold.
>>
>> This PR augments ZipInputStream.readEnd to also assume 8-byte sizes if the ZipEntry includes a Zip64 extra information field AND the 'compressed size' and 'uncompressed size' have the expected Zip64 "magic" value 0xFFFFFFFF. This brings ZipInputStream into alignment with the APPNOTE format spec:
>>
>>
>> When extracting, if the zip64 extended information extra
>> field is present for the file the compressed and
>> uncompressed sizes will be 8 byte values.
>>
>>
>> While small Zip64 files with 8-byte data descriptors are not commonly found in the wild, it is possible to create one using the Info-ZIP command line `-fd` flag:
>>
>> `echo hello | zip -fd > hello.zip`
>>
>> The PR also adds a test verifying that such a small Zip64 file can be parsed by ZipInputStream.
>
> Eirik Bjørsnøs has updated the pull request incrementally with two additional commits since the last revision:
>
> - Remove trailing whitespace
> - Remove trailing whitespace
src/java.base/share/classes/java/util/zip/ZipInputStream.java line 657:
> 655: * @param size the value of the 'uncompressed size' field in the LOC
> 656: */
> 657: private boolean expect64BitDataDescriptor(byte[] extra, int flag, long csize, long size) {
Suggestion:
private boolean expect64BitDataDescriptor(byte[] extra, int flag, long csize, long size) {
test/jdk/java/util/zip/ZipInputStream/Zip64DataDescriptor.java line 113:
> 111: // This ZIP has the regular 4-bit data descriptor
> 112:
> 113: byte[] extra = new byte[Long.BYTES + Long.BYTES + Short.BYTES * 2]; // Size of a regular Zip64 extra field
Suggestion:
byte[] extra = new byte[Long.BYTES + Long.BYTES + Short.BYTES * 2]; // Size of a regular Zip64 extra field
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/12524#discussion_r1452996737
PR Review Comment: https://git.openjdk.org/jdk/pull/12524#discussion_r1452996515
More information about the core-libs-dev
mailing list