RFR: 8327138: Clean up status management in cdsConfig.hpp and CDS.java
Ioi Lam
iklam at openjdk.org
Sat Mar 2 01:22:16 UTC 2024
A few clean ups:
1. Rename functions like "`s_loading_full_module_graph()` to `is_using_full_module_graph()`. The meaning of "loading" is not clear: it might be interpreted as to cover only the period where the artifact is being loaded, but not the period after the artifact is completely loaded. However, the function is meant to cover both periods, so "using" is a more precise term.
2. The cumbersome sounding `disable_loading_full_module_graph()` is changed to `stop_using_full_module_graph()`, etc.
3. The status of `is_using_optimized_module_handling()` is moved from metaspaceShared.hpp to cdsConfig.hpp, to be consolidated with other types of CDS status.
4. The status of CDS was communicated to the Java class `jdk.internal.misc.CDS` by ad-hoc native methods. This is now changed to a single method, `CDS.getCDSConfigStatus()` that returns a bit field. That way we don't need to add a new native method for each type of status.
5. `CDS.isDumpingClassList()` was a misnomer. It's changed to `CDS.isLoggingLambdaFormInvokers()`.
-------------
Commit messages:
- 8327138: Clean up status management in cdsConfig.hpp and CDS.java
Changes: https://git.openjdk.org/jdk/pull/18095/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=18095&range=00
Issue: https://bugs.openjdk.org/browse/JDK-8327138
Stats: 191 lines in 19 files changed: 43 ins; 53 del; 95 mod
Patch: https://git.openjdk.org/jdk/pull/18095.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/18095/head:pull/18095
PR: https://git.openjdk.org/jdk/pull/18095
More information about the core-libs-dev
mailing list