RFR: 8327138: Clean up status management in cdsConfig.hpp and CDS.java [v5]
Ioi Lam
iklam at openjdk.org
Sat Mar 9 00:50:17 UTC 2024
> A few clean ups:
>
> 1. Rename functions like "`s_loading_full_module_graph()` to `is_using_full_module_graph()`. The meaning of "loading" is not clear: it might be interpreted as to cover only the period where the artifact is being loaded, but not the period after the artifact is completely loaded. However, the function is meant to cover both periods, so "using" is a more precise term.
>
> 2. The cumbersome sounding `disable_loading_full_module_graph()` is changed to `stop_using_full_module_graph()`, etc.
>
> 3. The status of `is_using_optimized_module_handling()` is moved from metaspaceShared.hpp to cdsConfig.hpp, to be consolidated with other types of CDS status.
>
> 4. The status of CDS was communicated to the Java class `jdk.internal.misc.CDS` by ad-hoc native methods. This is now changed to a single method, `CDS.getCDSConfigStatus()` that returns a bit field. That way we don't need to add a new native method for each type of status.
>
> 5. `CDS.isDumpingClassList()` was a misnomer. It's changed to `CDS.isLoggingLambdaFormInvokers()`.
Ioi Lam has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains five additional commits since the last revision:
- Merge branch 'master' into 8327138-clean-up-cdsConfig-and-CDS-java
- @dholmes-ora comments -- white spaces and copyright
- more alignment
- fixed alignments
- 8327138: Clean up status management in cdsConfig.hpp and CDS.java
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/18095/files
- new: https://git.openjdk.org/jdk/pull/18095/files/c8f08f7f..25c19bb4
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=18095&range=04
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=18095&range=03-04
Stats: 82460 lines in 929 files changed: 7471 ins; 72858 del; 2131 mod
Patch: https://git.openjdk.org/jdk/pull/18095.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/18095/head:pull/18095
PR: https://git.openjdk.org/jdk/pull/18095
More information about the core-libs-dev
mailing list