RFR: 8343436: Regression in StackMapGenerator after JDK-8339205

Chen Liang liach at openjdk.org
Fri Nov 1 14:12:30 UTC 2024


On Fri, 1 Nov 2024 13:50:39 GMT, Adam Sotona <asotona at openjdk.org> wrote:

> This patch fixes regression in StackMapGenerator caused by JDK-8339205 + added test.
> 
> Please review.
> 
> Thanks,
> Adam

Seems we need to fix all the dup methods too. `checkStack` takes a usable max index instead of an exclusive end index so it's super confusing.

Maybe we can rename `checkStack` to `checkMaxStack` and use the exclusive end, like what we are doing with `stackSize` and `frameMaxStack`, to reduce confusions?

-------------

Changes requested by liach (Reviewer).

PR Review: https://git.openjdk.org/jdk/pull/21828#pullrequestreview-2410140634
PR Comment: https://git.openjdk.org/jdk/pull/21828#issuecomment-2451936575


More information about the core-libs-dev mailing list