RFR: 8338383: Implement JEP 491: Synchronize Virtual Threads without Pinning [v28]
Patricio Chilano Mateo
pchilanomate at openjdk.org
Tue Nov 5 01:43:58 UTC 2024
On Mon, 4 Nov 2024 05:52:16 GMT, Alan Bateman <alanb at openjdk.org> wrote:
>> src/hotspot/share/classfile/javaClasses.cpp line 2107:
>>
>>> 2105:
>>> 2106: jlong java_lang_VirtualThread::waitTimeout(oop vthread) {
>>> 2107: return vthread->long_field(_timeout_offset);
>>
>> Not sure what motivated the name change but it seems odd to have the method named differently to the field it accesses. ??
>
> It was initially parkTimeout and waitTimeout but it doesn't require two fields as you can't be waiting in Object.wait(timeout) and LockSupport.parkNanos at the same time. So the field was renamed, the accessors here should probably be renamed too.
Renamed accessors.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/21565#discussion_r1828615772
More information about the core-libs-dev
mailing list