RFR: 8035271: Incorrect indentation of LineNumberTable/LocalVariableTable/Exception table/LocalVariableTypeTable/StackMapTable/RuntimeVisibleTypeAnnotations in verbose mode
Jonathan Lampérth
duke at openjdk.org
Tue Nov 26 09:17:36 UTC 2024
On Mon, 25 Nov 2024 15:54:40 GMT, Jorn Vernee <jvernee at openjdk.org> wrote:
> > Add code header for only -l case?
>
> I think that is the right move. `LineNumberTable`, and others listed here: https://docs.oracle.com/javase/specs/jvms/se23/html/jvms-4.html#jvms-4.7-320 are/can be sub-attributes of the code attribute. So I think it makes sense to render them under `Code:`.
I have added this.
Notably I opted to split `writeInternal` into `writeMinimal` and `writeVerbose` as the logic was getting a little unreadable. (things like `if (!minimal || options.showLineAndLocalVariableTables)`). Although some added duplication, I think this is more readable.
-------------
PR Comment: https://git.openjdk.org/jdk/pull/22359#issuecomment-2500072948
More information about the core-libs-dev
mailing list