RFR: 8339320: Optimize ClassFile Utf8EntryImpl#inflate [v3]

Chen Liang liach at openjdk.org
Fri Oct 4 16:11:40 UTC 2024


On Wed, 25 Sep 2024 01:10:04 GMT, Shaojin Wen <swen at openjdk.org> wrote:

>> A very small optimization, split the large method inflate, split the infrequently used paths into a method inflateCHAR
>
> Shaojin Wen has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 10 commits:
> 
>  - inflateNonAscii
>  - Merge remote-tracking branch 'upstream/master' into optim_class_file_pool_inflat_202408
>    
>    # Conflicts:
>    #	src/java.base/share/classes/jdk/internal/classfile/impl/AbstractPoolEntry.java
>  - Merge remote-tracking branch 'origin/optim_class_file_pool_inflat_202408' into optim_class_file_pool_inflat_202408
>  - Update src/java.base/share/classes/jdk/internal/classfile/impl/AbstractPoolEntry.java
>    
>    Co-authored-by: ExE Boss <3889017+ExE-Boss at users.noreply.github.com>
>  - Update src/java.base/share/classes/jdk/internal/classfile/impl/AbstractPoolEntry.java
>    
>    Co-authored-by: ExE Boss <3889017+ExE-Boss at users.noreply.github.com>
>  - optimize Utf8EntryImpl inflate
>  - Merge remote-tracking branch 'upstream/master' into optim_class_file_pool_inflat_202408
>    
>    # Conflicts:
>    #	src/java.base/share/classes/jdk/internal/classfile/impl/AbstractPoolEntry.java
>  - Suggestions from @liach
>  - fix build error
>  - optimize Utf8EntryImpl inflate

src/java.base/share/classes/jdk/internal/classfile/impl/AbstractPoolEntry.java line 257:

> 255:         }
> 256: 
> 257:         private void inflateNonAscii(int singleBytes, int hash) throws ConstantPoolException {

Suggestion:

        private void inflateNonAscii(int singleBytes, int hash) {

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/20767#discussion_r1787935791


More information about the core-libs-dev mailing list