RFR: 8338544: Dedicated Array class descriptor implementation [v4]

Chen Liang liach at openjdk.org
Fri Oct 11 14:48:46 UTC 2024


> @cl4es discovered that Stack Map generation in ClassFile API uses `componentType` and `arrayType` for `aaload` `aastore` instructions, which are currently quite slow. We can split out array class descriptors from class or interfaces to support faster `arrayType` and `componentType` operations.
> 
> Tentative, as I currently have no way to measure the actual impact of this patch on the startup performance; however, this made the `ClassDesc` implementations much cleaner.

Chen Liang has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 12 commits:

 - Mandy reviews
 - Merge branch 'master' of https://github.com/openjdk/jdk into feature/array-cd
 - mlchung suggestions: elementType, improve utility methods
 - class or interface descriptor renamed for clarity
 - Merge branch 'master' of https://github.com/openjdk/jdk into feature/array-cd
 - Cleanup after merge
 - Merge branch 'master' of https://github.com/openjdk/jdk into feature/array-cd
 - Merge branch 'master' of https://github.com/openjdk/jdk into feature/array-cd
 - Compile error
 - Redundant import
 - ... and 2 more: https://git.openjdk.org/jdk/compare/61338661...e65fa6aa

-------------

Changes: https://git.openjdk.org/jdk/pull/20665/files
  Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=20665&range=03
  Stats: 790 lines in 17 files changed: 425 ins; 236 del; 129 mod
  Patch: https://git.openjdk.org/jdk/pull/20665.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/20665/head:pull/20665

PR: https://git.openjdk.org/jdk/pull/20665


More information about the core-libs-dev mailing list