RFR: 8338544: Dedicated Array class descriptor implementation [v5]

Chen Liang liach at openjdk.org
Tue Oct 22 04:32:26 UTC 2024


> @cl4es discovered that Stack Map generation in ClassFile API uses `componentType` and `arrayType` for `aaload` `aastore` instructions, which are currently quite slow. We can split out array class descriptors from class or interfaces to support faster `arrayType` and `componentType` operations.
> 
> Tentative, as I currently have no way to measure the actual impact of this patch on the startup performance; however, this made the `ClassDesc` implementations much cleaner.

Chen Liang has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 16 commits:

 - Merge branch 'master' of https://github.com/openjdk/jdk into feature/array-cd
 - Merge
 - object array desc constant
 - Merge branch 'master' of https://github.com/openjdk/jdk into feature/array-cd
 - Mandy reviews
 - Merge branch 'master' of https://github.com/openjdk/jdk into feature/array-cd
 - mlchung suggestions: elementType, improve utility methods
 - class or interface descriptor renamed for clarity
 - Merge branch 'master' of https://github.com/openjdk/jdk into feature/array-cd
 - Cleanup after merge
 - ... and 6 more: https://git.openjdk.org/jdk/compare/8bcd4920...62deed8b

-------------

Changes: https://git.openjdk.org/jdk/pull/20665/files
  Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=20665&range=04
  Stats: 829 lines in 19 files changed: 445 ins; 251 del; 133 mod
  Patch: https://git.openjdk.org/jdk/pull/20665.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/20665/head:pull/20665

PR: https://git.openjdk.org/jdk/pull/20665


More information about the core-libs-dev mailing list