RFR: 8344706: Compiler Implementation of Compact Source Files and Instance Main Methods [v2]
Stuart Marks
smarks at openjdk.org
Mon Apr 7 19:47:21 UTC 2025
On Mon, 7 Apr 2025 18:49:33 GMT, Chen Liang <liach at openjdk.org> wrote:
>> I used "internal objects" because I wanted to avoid naming concrete classes, which might or might not be used. Previous drafts mentioned BufferedReader, InputStreamReader, and CharsetDecoder.
>>
>> I could replace "internal objects" with something more descriptive like "objects to handle buffering and charset decoding" but I'd still need a noun phrase to refer to them later. Maybe "buffering and decoding objects" ?
>
> Can we rephrase the 1st sentence to read:
> "The `readln()` and `readln(String)` methods in this class decode bytes read from `System.in` into characters."
>
> And remove the last "these internal objects" sentence.
>
> And for the next paragraph, change the first line to:
> "The `readln` methods may buffer additional bytes..."
>
> So we remove references to "internal objects."
I'm in the midst of rewriting all of this stuff. The main concern here is that applications can use System.in more or less as they please (presumably without buffering) _until_ the first call to a `readln` method, at which time _something happens_ and effectively the application cannot use System.in anymore. I'll post the revision when I've finished it.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/24438#discussion_r2031907101
More information about the core-libs-dev
mailing list