RFR: 8351740: Clean up some code around initialization of encoding properties [v3]

Stuart Marks smarks at openjdk.org
Thu Apr 10 19:37:40 UTC 2025


On Thu, 10 Apr 2025 18:14:52 GMT, Stuart Marks <smarks at openjdk.org> wrote:

>> Some of the code that creates various encoding properties at JVM initialization time, such as file.encoding and native.encoding, could use some cleaning up. Cleanup is fairly minimal and should be mostly behavior-preserving. Changes include the following:
>> 
>> * In the java_props.h and java_props_md.c files, add documentation and asserts that the sprops.encoding and sprops.sun_jnu_encoding members are always set to non-NULL by the platform-specific code.
>> 
>> * In SystemProps.java, remove a null check that is now extraneous based on the above assertion.
>> 
>> * In SystemProps.java, rearrange logic (with no behavior change) around handling of the "COMPAT" value for the file.encoding property.
>> 
>> * In SystemProps.Raw, rename the platform properties array index from _file_encoding_NDX to _native_encoding_NDX.
>> 
>> * In SystemProps.Raw.cmdProperties(), adjust the HashMap size computation. This should actually avoid resizing of the HashMap (unlike the earlier code).
>> 
>> * Adjust various comments in several places for clarity and correctness.
>
> Stuart Marks has updated the pull request incrementally with one additional commit since the last revision:
> 
>   Update copyrights; change var to String in a couple places.

Need re-review on this after my updates, if anyone gets a chance. Thanks.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/24463#issuecomment-2794961461


More information about the core-libs-dev mailing list