RFR: 8347334: JimageDiffGenerator code clean-ups [v2]
Archie Cobbs
acobbs at openjdk.org
Mon Jan 13 14:25:53 UTC 2025
On Mon, 13 Jan 2025 10:47:41 GMT, Severin Gehwolf <sgehwolf at openjdk.org> wrote:
>> (Getting into marginal returns on comments here, so my apologies for nitpicking)
>>
>> The loop could be simplified even further...
>>
>> while (true) {
>> int bytesRead1 = is1.readNBytes(buf1, 0, buf1.length);
>> int bytesRead2 = is2.readNBytes(buf2, 0, buf2.length);
>> if (!Arrays.equals(buf1, 0, bytesRead1, buf2, 0, bytesRead2))
>> return false;
>> if (bytesRead1 == 0)
>> return true;
>> }
>
> @archiecobbs @AlanBateman Any thoughts? Is this good to go? Thanks!
Hi @jerboaa, LGMT - my comments are addressed (thanks :) I'm not an official reviewer though.
-------------
PR Comment: https://git.openjdk.org/jdk/pull/23014#issuecomment-2587238153
More information about the core-libs-dev
mailing list