<html><head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
  </head>
  <body>
    <font size="4"><font face="monospace">Please be mindful of the
        request Viktor made: for feedback on the approach and the API
        concepts.  It should be pretty clear that low-level details like
        "unsupportedCombiner" are many levels down below "approach and
        concepts".  (And, you know the rule: when you bikeshed on a
        low-level detail when asked for high-level comments, you've
        forfeited the right to have further opinions about the
        concepts.)<br>
        <br>
        In any case, I think your high-level comments seem to be: you
        prefer a direction where, rather than creating new
        possibly-stateful, possibly-not-parallel ops, instead beef up
        Collector and let people start a new stream.  <br>
      </font></font><br>
    <div class="moz-cite-prefix">On 6/29/2023 8:13 AM, <a class="moz-txt-link-abbreviated" href="mailto:forax@univ-mlv.fr">forax@univ-mlv.fr</a>
      wrote:<br>
    </div>
    <blockquote type="cite" cite="mid:1268634283.92998237.1688040833988.JavaMail.zimbra@univ-eiffel.fr">
      <blockquote style="border-left:2px solid
#1010FF;margin-left:5px;padding-left:5px;color:#000;font-weight:normal;font-style:normal;text-decoration:none;font-family:Helvetica,Arial,sans-serif;font-size:12pt;">
        <div>
          <div style="font-family: arial, helvetica, sans-serif;
            font-size: 12pt; color: rgb(0, 0, 0);">
            <div class="elementToProof">
              <div class="elementToProof"><br>
              </div>
              >The idea of unsupportedCombiner() seems out of place,
              like a patch to be able to clobble different things
              together. I'm not sure to understand why it's needed for a
              Gatherer, and why it is not needed for Collectors ?<br>
              <div class="elementToProof"><br>
              </div>
              <div class="elementToProof">Nothing prevents us from
                treating a `null` combiner the same way. My primary
                reason for making it a dedicated thing was to be able to
                differentiate a possible bug (user passing in a null
                reference inadvertently) from explicitly stating that a
                combiner does not exist from this operation.</div>
              <div class="elementToProof"><br>
              </div>
              <div class="elementToProof"><i>unsupportedCombiner()</i>
                as an artifact can be completely hidden if desired, as
                <i>Gatherer.of()</i> can have permutations without
                specifying a combiner, and the
                <i>default method</i> of Gatherer.combiner() could
                return <i>unsupportedCombiner()</i>. I opted not to do
                this initially, because I felt like being explicit about
                not having a combiner means that it is a concious
                decision by the implementor of the Gatherer.</div>
            </div>
          </div>
        </div>
      </blockquote>
      <div><br>
      </div>
      <div>My question is more, why do we need this unsupportedCombiner
        on a Gatherer and not on a Collector ?</div>
    </blockquote>
    <br>
  </body>
</html>