CRac example usage

Gabriele Cardosi gcardosi at
Wed Nov 2 15:39:33 UTC 2022

Hi Anton,
here's the log

jdk.crac.impl.CheckpointOpenFileException: /var/lib/sss/mc/passwd
        at java.base/jdk.crac.Core.translateJVMExceptions(
        at java.base/jdk.crac.Core.checkpointRestore1(
        at java.base/jdk.crac.Core.checkpointRestore(
        at java.base/

By the way, I talked of this with the original proposer of the workaround,
and he also confirmed the same issue on rhel 8.6

There should be something slightly different, but I could not understand
exactly what.



On Wed, Nov 2, 2022 at 4:28 PM Anton Kozlov <akozlov at> wrote:

> Hi Gabriele,
> On 10/10/22 16:29, Gabriele Cardosi wrote:
> > I'm trying to run the spring-boot example from the github repo.
> > I tried with the JDK 17 build, but it did not work due to the "java.base
> does not 'opens java.lang'" issue.
> In general, this mail list is not a good place for this discussion, github
> issues would be a better place.
> > Then I tried with the JDK 14 build, but this time I have the
> "jdk.crac.impl.CheckpointOpenFileException: /var/lib/sss/mc/passwd"
> exception.
> > I also tried with the workaround explained here (
> <
> but it did not work on my machine (RHEL 8.6).
> Could you provide more details about what you did and how does the output
> look? Because I'd expect the workaround to work.
> Thanks,
> Anton




Red Hat Ltd <>

gcardosi at    M: +39-3461717132
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the crac-dev mailing list