[crac] RFR: Move more FD tracking to java layer [v2]

Radim Vansa duke at openjdk.org
Mon Jun 12 12:46:21 UTC 2023

On Mon, 12 Jun 2023 12:16:42 GMT, Anton Kozlov <akozlov at openjdk.org> wrote:

>> src/java.base/share/classes/jdk/crac/impl/ExceptionHolder.java line 30:
>>> 28:     }
>>> 29: 
>>> 30:     public void reSuppress(Exception e) {
>> Was thinking about a better name... `adoptSuppressed`?
> I don't like the suggestion. What is the problem with the original name?

OK. It's just unclear, when reading the use `re` would be some acronym (just related to **R**estore**E**xceptions), otherwise it doesn't need the camelcasing (https://en.wiktionary.org/wiki/resuppress). Forget about it if you're satisfied with the current one.


PR Review Comment: https://git.openjdk.org/crac/pull/79#discussion_r1226610847

More information about the crac-dev mailing list