[rfc] netx: display file name in warning dialog
Omair Majid
omajid at redhat.com
Wed Sep 29 12:36:20 PDT 2010
Hi,
On 09/29/2010 03:04 PM, Dr Andrew John Hughes wrote:
> On 14:47 Wed 29 Sep , Omair Majid wrote:
>> Hi,
>>
>> The attached patch adds the filename to the file access warning dialogs
>> used by netx.
>>
>> Any comments?
>
>
> I think it would be cleaner to store the result of (visibleChars - 3) / 2 rather than
> computing it twice. I also don't see how the change to XExtendedService is relevant;
> could you explain?
>
Thanks for the feedback. Making a few changes makes the code quite a bit
more readable. It now only computes (visibleChars - 3)/2 once. I have
also replace most magic numbers with descriptive constants and tweaked
the minimum lengths for affixes from 1 to 4.
In the current implementation, the extras[] array is used to pass
information relevant only to specific types of warnings. As an example,
in the case of a NetworkAccess warning extras[0] contains the address
of the destination. This patch makes use of extras[0] (if present) for
the file name. XExtendedService is used to open files where the filename
is known. My changes to XExtenededService pass the filename as
extras[0]. (There are other cases where we dont know the name of the
file - for example if XFileOpenService is used which shows a
JFileChooser to the user for selecting a file). I added a comment as I
noticed that even though it prompts the user for a _read_ request, the
returned FileContents object can be used for writing as well (if the
user has permissions, of course).
> Otherwise, looks good.
Thanks,
Omair
-------------- next part --------------
A non-text attachment was scrubbed...
Name: icedtea6-jnlp-filename-in-accesswarningpane-02.patch
Type: text/x-patch
Size: 6762 bytes
Desc: not available
Url : http://mail.openjdk.java.net/pipermail/distro-pkg-dev/attachments/20100929/034b051b/icedtea6-jnlp-filename-in-accesswarningpane-02.patch
More information about the distro-pkg-dev
mailing list