[RFC][Icedtea-web]: Changed how cache works.

Omair Majid omajid at redhat.com
Tue Apr 5 15:43:09 PDT 2011


On 04/05/2011 03:20 PM, Andrew Su wrote:

Thanks for the explanations!

> File:
>    <UserCacheDir>/RecentlyUsed
> Desc:
>    Keep track of the most recently accessed file. It can work without
>    this file if we traverse the directory for this information.
> Format:
>    This file is kept to how a regular properties file works
>    Key=Value
>    The Key consist of time accessed followed by the folder number.
>    Example:
>    13020173404=<UserCacheDir>/4/http/www.example.come/example.jar
>    In this case the 4 at the end is the cache directory.
>

 From reading the previous patch, I gather that the example should be 
13020173404<UserCacheDir>/4/http/www.example.come/example.jar=<UserCacheDir>/4/http/www.example.come/example.jar. 
Is that right?

>
> File:
>    <UserCacheDir>/<FolderNumber>/<Protocol>/<Domain>/<SubDir>/*.info
> Desc:
>    These files contain information about the file in the directory.
>    Such as file length(size), last-modified header from download, and
>    whether this file should be deleted at shutdown.
> Format:
>    Each line consist of a Key=Value pair to report the state of the
>    item.
>

Ah, I see. The versioning is a little strange and might make grepping a 
little harder. But I suppose it makes sense.

>
> The above mentioned files are the only ones that we change.
>
> Design:
>    It works similarly to the old cache with the addition of LRU and
>    separate per cache-entry directory.
>    During the initialization of the resource stage
>    (ResourceTracker.initializeResource()) Here we will try and grab
>    the most recently downloaded version of the cache-entry. If this
>    entry does not exist it will prepare a directory to store this
>    item. Now, to prevent another instance of plugin/javaws from
>    overwriting the file we lock the PropertiesFile associated with
>    this entry. If this file does exist, but not up to date then we
>    create a new directory to store the new file. The old entry is
>    marked for deletion at shutdown.
>

Isn't this susceptible to race conditions? Suppose javaws process A 
starts and downloads http://example.com/example.jar. Then process B 
starts and downloads an updated version of 
http://example.com/example.jar. Process B will mark process A's file as 
ready for deletion right? If process B shuts down first (before A shuts 
down) then B will delete A's jars.

>    Onto the downloading stage. This only happens if we have found
>    the entry to be outdated or does not exist (from above). In here
>    we try to lock on the PropertiesFile, and block if it is either
>    being requested, or already in downloading progress. It is okay
>    to block here because if there is a download for this file in
>    progress, we can't use it until it is completed anyways.
>
>    Loading the jars... nothing changed here.
>
>    JVM Shutdown. At this point we will remove all compressed
>    downloads and the folders they extract to since the check for
>    size difference will always be true, it will try to redownload
>    anyways. This can save some space at the end of the day.
>    After removing these entries, it will proceed to removing all
>    folders not being tracked by RecentlyUsed. (To get rid of the
>    currently cached items before patch).
>
>> >
>> >  I would love it if the response consists of patch with a new class per
>> >  file/directory introduced/modified/repurposed and each class contains
>> >  (as comments) the purpose and format :D
> I've move the policy to it's own class. Where it will handle the
>
> I've refactored the managing of the LRU policy into its own class.
> However modifying info class will not be moved anywhere since that
> is already handled by CacheEntry. The directories being created
> didn't seem to fit to be its own class either, can not pass it
> onto other plugin/javaws instances without having to traverse
> the directories (I wanted to avoid that).
>

I have left a few comments in-line, but we really should sort out the 
overall design (and any possible issues with it) before doing code reviews.

> Cheers,
>    Andrew
>
>
> 20110405_cache_v12.patch
>
>
> diff -r eea730466b87 ChangeLog
> --- a/ChangeLog	Tue Apr 05 14:38:22 2011 -0400
> +++ b/ChangeLog	Tue Apr 05 15:21:46 2011 -0400
> @@ -1,3 +1,26 @@
> +2011-04-05  Andrew Su<asu at redhat.com>
> +
> +        * netx/net/sourceforge/jnlp/cache/CacheEntry.java:
> +        (markForDelete, lock, unlock): New methods.
> +        * netx/net/sourceforge/jnlp/cache/CacheUtil.java:
> +        (getCacheFile): Changed to look for most recently used item, and when
> +        not found create a new entry.
> +        (makeNewCacheFile, lockFile, unlockFile, removeUntrackedDirectories,
> +        cleanCache, getCacheFileIfExist): new methods.
> +        * netx/net/sourceforge/jnlp/cache/ResourceTracker.java:
> +        (downloadResource): Changed to wait if we are already downloading the
> +        file. If file downloaded is compressed, mark compressed and extracted
> +        files for delete at shutdown.
> +        (initializeResource): Added checks for when the cache needs updating
> +        to create new folder entry.
> +        * netx/net/sourceforge/jnlp/runtime/JNLPClassLoader.java:
> +        (JNLPClassLoader): Change order so that we get resources first then
> +        check permissions for the jars.
> +        * netx/net/sourceforge/jnlp/util/FileUtils.java:
> +        (getFileLock): New method.
> +        * netx/net/sourceforge/jnlp/cache/CacheLRUPolicy.java: New class.
> +        This class handles the sorting of items when they are set to update.
> +
>   2011-04-05  Denis Lila<dlila at redhat.com>
>
>   	* plugin/icedteanp/java/netscape/javascript/JSObject.java:
> diff -r eea730466b87 netx/net/sourceforge/jnlp/cache/CacheEntry.java
> --- a/netx/net/sourceforge/jnlp/cache/CacheEntry.java	Tue Apr 05 14:38:22 2011 -0400
> +++ b/netx/net/sourceforge/jnlp/cache/CacheEntry.java	Tue Apr 05 15:21:46 2011 -0400
> @@ -162,4 +162,25 @@
>           properties.store();
>       }
>
> +    /**
> +     * Mark this entry for deletion at shutdown.
> +     */
> +    public void markForDelete() { // once marked it should not be unmarked.
> +        properties.setProperty("delete", Boolean.toString(true));
> +    }
> +
> +    /**
> +     * Lock cache item.
> +     */
> +    protected void lock() {
> +        CacheUtil.lockFile(properties);
> +    }
> +
> +    /**
> +     * Unlock cache item.
> +     */
> +    protected void unlock() {
> +        CacheUtil.unlockFile(properties);
> +    }
> +
>   }
> diff -r eea730466b87 netx/net/sourceforge/jnlp/cache/CacheLRUPolicy.java
> --- /dev/null	Thu Jan 01 00:00:00 1970 +0000
> +++ b/netx/net/sourceforge/jnlp/cache/CacheLRUPolicy.java	Tue Apr 05 15:21:46 2011 -0400
> @@ -0,0 +1,179 @@

Please add a license header to this file.

> +package net.sourceforge.jnlp.cache;
> +
> +
> +/**
> + * This class helps maintain the ordering of most recently use items across
> + * multiple jvm instances.
> + *
> + * @author Andrew Su (asu at redhat.com,andrew.su at utoronto.ca)
> + *
> + */
> +public class CacheLRUPolicy {
> +

I thought a cache replacement policy class will specify which entries 
(or files) to keep (or remove) given a set of constraints. This class 
looks more like another cache class. I suppose it's great to have a 
wrapper class to parse/update the cache metadata, but calling it a 
policy might be a little misleading.

> +    /* lock for the file RecentlyUsed */
> +    private static FileLock fl = null;
> +
> +    /* location of cache directory */
> +    private static final String cacheDir = new File(JNLPRuntime.getConfiguration().getProperty(DeploymentConfiguration.KEY_USER_CACHE_DIR)).getPath();
> +


> +    /**
> +     * This adds a new entry to file.
> +     *
> +     * @param identifier value to append to key.
> +     * @param path path to cache item.
> +     * @return true if we successfully added to map, false otherwise.
> +     */
> +    public synchronized boolean addEntry(String identifier, String path) {
> +        String key = Long.toString(System.currentTimeMillis()) + identifier;
> +        if (cacheOrder.containsKey(key)) return false;
> +        cacheOrder.setProperty(key, path);
> +        return true;
> +    }
> +
> +    /**
> +     * This removed an entry from our map.
> +     *
> +     * @param key key we want to remove.
> +     * @return true if we successfully removed key from map, false otherwise.
> +     */
> +    public synchronized boolean removeEntry(String key) {
> +        if (!cacheOrder.containsKey(key)) return false;
> +        cacheOrder.remove(key);
> +        return true;
> +    }
> +
> +    /**
> +     * This updates the given key to reflect it was recently accessed.
> +     *
> +     * @param oldKey Key we wish to update.
> +     * @return true if we successfully updated value, false otherwise.
> +     */
> +    public synchronized boolean updateEntry(String oldKey) {
> +        if (!cacheOrder.containsKey(oldKey)) return false;
> +        String value = cacheOrder.getProperty(oldKey);
> +
> +        String str = cacheOrder.getProperty(oldKey);
> +        str = str.substring(cacheDir.length());
> +        int index = str.indexOf(File.separatorChar, 1);
> +        String folder = str.substring(1, index);
> +
> +        cacheOrder.remove(oldKey);
> +        cacheOrder.setProperty(Long.toString(System.currentTimeMillis()) + folder, value);
> +        return true;
> +    }
> +

I like how we have similar methods - addEntry/updateEntry/removeEntry. 
But their arguments are not consistent at all. Remove and update expect 
keys, but add only expects an identifier.


> +    /**
> +     * Lock the file to have exclusive access.
> +     */
> +    public synchronized void lock() {
> +        try {
> +            File f = new File(cacheOrder.getStoreFile().getPath());
> +            if (!f.exists()) {
> +                FileUtils.createParentDir(f);
> +                FileUtils.createRestrictedFile(f, true);
> +            }
> +            fl = FileUtils.getFileLock(f.getPath(), false, true);
> +        } catch (OverlappingFileLockException e) { // if overlap we just increase the count.
> +        } catch (Exception e) { // We didn't get a lock..
> +            e.printStackTrace();
> +        }
> +        if (fl != null) lockCount++;
> +    }
> +
> +    /**
> +     * Unlock the file.
> +     */
> +    public synchronized void unlock() {
> +        if (fl != null) {
> +            lockCount--;
> +            try {
> +                if (lockCount == 0) {
> +                    fl.release();
> +                    fl.channel().close();
> +                    fl = null;
> +                }
> +            } catch (IOException e) {
> +                e.printStackTrace();
> +            }
> +        }
> +    }
> +

The locks ensure ordering between processes so we still need another set 
of locks to ensure consistency within the same process. Perhaps you 
might also want to acquire a java.util.concurrent.locks.Lock here?

> +    public synchronized String getValue(String key) {
> +        return cacheOrder.getProperty(key);
> +    }
> +

A more descriptive name for this method might be more appropriate.

> diff -r eea730466b87 netx/net/sourceforge/jnlp/cache/CacheUtil.java
> --- a/netx/net/sourceforge/jnlp/cache/CacheUtil.java	Tue Apr 05 14:38:22 2011 -0400
> +++ b/netx/net/sourceforge/jnlp/cache/CacheUtil.java	Tue Apr 05 15:21:46 2011 -0400
> @@ -39,6 +42,18 @@
>    */
>   public class CacheUtil {
>
> +    private static final String cacheDir = new File(JNLPRuntime.getConfiguration().getProperty(DeploymentConfiguration.KEY_USER_CACHE_DIR)).getPath(); // Do this with file to standardize it.
> +

Please try to keep lines to 80 chars. Also, please try and use 
UPPER_CASE_VARIABLE_NAME for constants.

> -        } catch (Exception ex) {
> -            if (JNLPRuntime.isDebug())
> -                ex.printStackTrace();
> +            // We need to reload the cacheOrder file each time
> +            // since another plugin/javaws instance may have updated it.
> +            policy.load();
> +            cacheFile = getCacheFileIfExist(urlToPath(source, ""));

I wonder how other methods that use urlToPath work with the new cache 
location...


> diff -r eea730466b87 netx/net/sourceforge/jnlp/cache/ResourceTracker.java
> --- a/netx/net/sourceforge/jnlp/cache/ResourceTracker.java	Tue Apr 05 14:38:22 2011 -0400
> +++ b/netx/net/sourceforge/jnlp/cache/ResourceTracker.java	Tue Apr 05 15:21:46 2011 -0400


> +            if (!downloadLocationFile.exists()) {

> +                while (-1 != (rlen = in.read(buf))) {
> +                    resource.transferred += rlen;
> +                    out.write(buf, 0, rlen);
>                   }

resource.transferred is never updated if the download file already 
exists. Perhaps you might want to bump it at the end? I am not sure how 
it interacts with progress indicators at this point.





More information about the distro-pkg-dev mailing list