[icedtea-web] RFC: Fix handling of 0x0 applets for chromium

Deepak Bhole dbhole at redhat.com
Thu Mar 3 14:54:38 PST 2011


* Omair Majid <omajid at redhat.com> [2011-03-03 17:48]:
> On 03/03/2011 05:42 PM, Deepak Bhole wrote:
> >* Deepak Bhole<dbhole at redhat.com>  [2011-03-03 11:34]:
> >>* Omair Majid<omajid at redhat.com>  [2011-03-03 11:26]:
> >>>>>
> >>>>
> >>>>Yeah it is just one line being duplicated once. Didn't seem worth it to
> >>>>create a function for it.
> >>>>
> >>>
> >>>Yeah, I noticed that. Still, we should try to avoid duplicate code,
> >>>as it causes breakage just like this.
> >>>
> >>
> >>I don't see how a function could've avoided it. It would still have to
> >>be called from get_scriptable_object and would've been missed.
> >>
> >
> >Doh. Realized later what you meant/how a function would have prevented
> >it :/
> >
> >New patch with common code split off into a separate function. Okay for
> >1.0 and HEAD?
> >
> 
> Sure. The old patch was fine too; this is better. Okay for HEAD/1.0.
> 
> >ChangeLog:
> >2011-03-03  Deepak Bhole<dbhole at redhat.com>
> >
> >     * plugin/icedteanp/IcedTeaNPPlugin.cc
> >     (plugin_send_initialization_message): New method. Sends initialization
> >     information to the Java side.
> >     (ITNP_SetWindow): Call the new plugin_send_initialization_message
> >     function.
> >     (get_scriptable_object): Same.
> 
> Isn't it more common to use "Likewise"?
> 

Is it? I've been using "Same" all this time.. didn't know there was a
standard for it. I'll change it before committing.

Cheers,
Deepak

> Cheers,
> Omair



More information about the distro-pkg-dev mailing list