[RFC][icedtea-web:netx]: handle error code returning functions

Denis Lila dlila at redhat.com
Fri Mar 11 10:46:18 PST 2011

> Not sure if that's entirely correct. A user may accidentally create a
> file with that name. exists() will return true even though it's not a
> directory. For robustness's sake, I think we should always explicitly
> check for a directory.

Right, I see.

> For ease of reading, may I recommend overloading this? If you create
> another method createParentDir(File f) which delegates to this by
> calling createParentDir(f, null), it might make other parts of the
> code
> easier to read.
> Also, please add JavaDocs.


Is it ok now?

Thank you,

----- Original Message -----
> On 03/10/2011 07:21 PM, Denis Lila wrote:
> > Hi.
> >
> >> >  I do have a few concerns noted inline below.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: deleteMkdirs_v3.patch
Type: text/x-patch
Size: 12680 bytes
Desc: not available
Url : http://mail.openjdk.java.net/pipermail/distro-pkg-dev/attachments/20110311/aeaa80de/deleteMkdirs_v3.patch 

More information about the distro-pkg-dev mailing list