[RFC][plugin]: make PluginObjectStore a singleton.

Deepak Bhole dbhole at redhat.com
Thu Mar 31 12:03:43 PDT 2011


* Denis Lila <dlila at redhat.com> [2011-03-31 14:54]:
> Hi.
> 
> The attached patch does what the subject says.
> 
> Ok to push?
> 

Please rename the instance to INSTANCE and method to getInstance to make
it clearer that it is a singleton in the caller as well.

Looks fine otherwise. Okay for commit after above change.

Cheers,
Deepak

> Thank you,
> Denis.

> diff -r cea9ea395406 ChangeLog
> --- a/ChangeLog	Thu Mar 31 14:35:01 2011 -0400
> +++ b/ChangeLog	Thu Mar 31 14:55:29 2011 -0400
> @@ -1,3 +1,13 @@
> +2011-03-31  Denis Lila  <dlila at redhat.com>
> +
> +	* plugin/icedteanp/java/sun/applet/PluginAppletSecurityContext.java
> +	(store): Make private and remove fixme to make private.
> +	* plugin/icedteanp/java/sun/applet/PluginObjectStore.java
> +	(PluginObjectStore): Make it a singleton using enum.
> +	(objects, counts, identifiers, lock, wrapped, nextUniqueIdentifier,
> +	 checkNeg): Made instance methods/members.
> +	(getTheStore): New static method.
> +
>  2011-03-31  Denis Lila  <dlila at redhat.com>
>  
>  	* plugin/icedteanp/java/sun/applet/AppletSecurityContextManager.java
> diff -r cea9ea395406 plugin/icedteanp/java/sun/applet/PluginAppletSecurityContext.java
> --- a/plugin/icedteanp/java/sun/applet/PluginAppletSecurityContext.java	Thu Mar 31 14:35:01 2011 -0400
> +++ b/plugin/icedteanp/java/sun/applet/PluginAppletSecurityContext.java	Thu Mar 31 14:55:29 2011 -0400
> @@ -225,8 +225,7 @@
>      private static Hashtable<ClassLoader, URL> classLoaders = new Hashtable<ClassLoader, URL>();
>      private static Hashtable<Integer, ClassLoader> instanceClassLoaders = new Hashtable<Integer, ClassLoader>();
>  
> -    // FIXME: make private
> -    public PluginObjectStore store = new PluginObjectStore();
> +    private PluginObjectStore store = PluginObjectStore.getTheStore();
>      private Throwable throwable = null;
>      private ClassLoader liveconnectLoader = ClassLoader.getSystemClassLoader();
>      int identifier = 0;
> diff -r cea9ea395406 plugin/icedteanp/java/sun/applet/PluginObjectStore.java
> --- a/plugin/icedteanp/java/sun/applet/PluginObjectStore.java	Thu Mar 31 14:35:01 2011 -0400
> +++ b/plugin/icedteanp/java/sun/applet/PluginObjectStore.java	Thu Mar 31 14:55:29 2011 -0400
> @@ -40,14 +40,21 @@
>  import java.util.HashMap;
>  import java.util.Map;
>  
> -public class PluginObjectStore {
> -    private static HashMap<Integer, Object> objects = new HashMap<Integer, Object>();
> -    private static HashMap<Integer, Integer> counts = new HashMap<Integer, Integer>();
> -    private static HashMap<Object, Integer> identifiers = new HashMap<Object, Integer>();
> -    private static final Object lock = new Object();
> +// Enums are the best way to implement singletons.
> +enum PluginObjectStore {
> +    THE_STORE;
>  
> -    private static boolean wrapped = false;
> -    private static int nextUniqueIdentifier = 1;
> +    private HashMap<Integer, Object> objects = new HashMap<Integer, Object>();
> +    private HashMap<Integer, Integer> counts = new HashMap<Integer, Integer>();
> +    private HashMap<Object, Integer> identifiers = new HashMap<Object, Integer>();
> +    private final Object lock = new Object();
> +
> +    private boolean wrapped = false;
> +    private int nextUniqueIdentifier = 1;
> +
> +    public static PluginObjectStore getTheStore() {
> +        return THE_STORE;
> +    }
>  
>      public Object getObject(Integer identifier) {
>          synchronized(lock) {
> @@ -78,7 +85,7 @@
>          }
>      }
>  
> -    private static boolean checkNeg() {
> +    private boolean checkNeg() {
>          if (nextUniqueIdentifier < 1) {
>              wrapped = true;
>              nextUniqueIdentifier = 1;




More information about the distro-pkg-dev mailing list