[RFC][icedtea-web] Rename JarSigner to JarCertVerifier
Danesh Dadachanji
ddadacha at redhat.com
Wed Apr 4 14:44:01 PDT 2012
Hi,
It's been discussed before that JarSigner is a terrible name for the class that does not ever sign jars. The purpose of JarSigner is to
perform various checks on all the jars passed to the plugin, specifically to go through and verify the jars' signers.
I propose a better name for it be JarCertVerifier. It implements CertVerifier so I think following the trend (similarly to
HttpsCertVerifier) is a good idea.
I've gone through the codebase and replaced every mention of JarSigner (ignore-case) to the more suitable naming convention.
I noticed that in the security dialog classes, "jarSigner" is the name of many parameters and passed through to the
constructors/methods. However, the type of all of these params is CertVerifier. I believe icedtea-web only ever uses these classes with
a CertVerifier object specifically of type JarSigner but it is potentially possible that they could be of another type that implements
CertVerifier. I do not think it's a good idea to name the params under this assumption/idea so I've renamed them to be more generic as
certVerifier. The big incentive behind this is that it confuses devs, I know I was thrown off momentarily by
SecurityDialog.getJarSigner returning an object of type CertVerifier.
I made the changes through Eclipse's Refactor->Rename command so everything was renamed properly. I also ran 'grep -ir jarsigner
icedtea-web/', the only things that showed up were in Makefile.am, acinclude.m4 and ChangeLog. The autoconf ones are correct in
remaining as jarsigner as this is referring to the binary jarsigner, not our lovely class.
All unit tests and reproducers that usually pass did.
Any comments? Can I push to HEAD?
Cheers,
Danesh
-------------- next part --------------
A non-text attachment was scrubbed...
Name: rename-jar-signer-01.patch
Type: text/x-patch
Size: 17555 bytes
Desc: not available
Url : http://mail.openjdk.java.net/pipermail/distro-pkg-dev/attachments/20120404/f5293a47/rename-jar-signer-01.patch
More information about the distro-pkg-dev
mailing list