[rfc][icedtea-web] known to fail annotation

Omair Majid omajid at redhat.com
Mon Jun 4 12:53:51 PDT 2012


On 05/23/2012 10:59 AM, Jiri Vanek wrote:
> On 05/22/2012 07:30 PM, Omair Majid wrote:
>> On 05/22/2012 08:56 AM, Jiri Vanek wrote:
>>> As agreed on IRC, Percentage removed. What do you think now?
>>
>> I am wondering what really differentiates KnownToFail from Ignore, aside
>> from the fact that we are processing the KnownToFail annotation. But we
>> could do the same for Ignore, right? Is it that tests makred with Ignore
>> are not run while tests marked with KnownToFail are run?
> 
> Yes. This is crucial difference.
>>
>> Something I am unclear about. Say I have this test case:
>>
>> class TestCase {
>>    @Test
>>    @KnownToFail
>>    public void someTestMethod() throws Exception {
>>      assertTrue(false);
>>    }
>> }
>>
>> What stat do you think should be printed?
>>
>> Passed: 0, Failed: 1, Ignored: 0
>>
>> or
>>
>> Passed: 0, Failed: 0, Ignored: 1
>> (with something to indicate the exepected failure?)
> 
> Well this is correct question. You saw my outputs below. (to print it as
> failed, and print somewhere that those are supposed to fail)  Are you ok
> with them?
> 

Yeah, a separate line should be fine for now.

I think it would be better to have just one line with the result
summarized. It's faster for humans to read and interpret. But I am not
sure how to reconcile that with a known reproducer that passes (or other
strange cases like that).

>>> diff -r 1088b2dffe49 tests/junit-runner/JunitLikeXmlOutputListener.java
>>> --- a/tests/junit-runner/JunitLikeXmlOutputListener.java    Tue May
>>> 22 12:08:17 2012 +0200
>>> +++ b/tests/junit-runner/JunitLikeXmlOutputListener.java    Tue May
>>> 22 14:32:43 2012 +0200
>>
>>> @@ -45,6 +47,7 @@
>>>       private static final String TEST_ELEMENT = "testcase";
>>>       private static final String BUGS = "bugs";
>>>       private static final String BUG = "bug";
>>> +    private static final String K2F = "knownToFail";
>>
>> A more xml-like version might be "known-to-fail" ;)
> 
> done (although I don`t like this convention ;)

Well, this is a subjective issue. So if you dont like it, please change
it back to something you are happy with :)

>>> +        } catch (Exception ex) {
>>> +            ex.printStackTrace();
>>> +        }
>>> +        Map<String, String>  testcaseAtts = new HashMap<String,
>>> String>(4);
>>>           NumberFormat formatter = new DecimalFormat("#0.0000");
>>>           String stringedTime = formatter.format(testTimeSeconds);
>>>           stringedTime.replace(",", ".");
>>
>> This replacement of comma with a dot looks strange. It looks like
>> something that should be handled by the localization code.
> 
> It is not related to this patch, I have not find quick way of fix.
> Adding to my todo!

Right. Sorry, I should have been clearer - I pointed out issues that
weren't related to your patch. You dont have to fix them (or explain
thme) in your patch.

>> This is probably the best argument I can point to for renaming
>> ClassCounter to ClassStat ;)
> 
> done - although did patch little bit messy.

I didn't mean to imply that you have to do it in this patch :) You can
split it out/do it later, if you want.

>> Anyway, please rename cc to "classStat" "testStat" or something.
> done!
>>
>>> @@ -45,7 +60,56 @@
>>>           int passed = result.getRunCount() -
>>> result.getFailureCount() - result.getIgnoreCount();
>>>           int failed = result.getFailureCount();
>>>           int ignored = result.getIgnoreCount();
>>> -        writer.println("Test results: passed: " + passed + ";
>>> failed: " + failed + "; ignored: " + ignored);
>>> +        writer.println("Test results ("+result.getRunCount()+"):
>>> passed: " + passed + "; failed: " + failed + "; ignored: " + ignored);
>>> +        writer.println("Test known to fail ("+totalK2F+"): passed: "
>>> + passedK2F + "; failed: " + failedK2F + "; ignored: " + ignoredK2F);
>>> +    }
>>
>> Are the builders prepared to handle this change in output?
> I have swap the lines so they will be affected with less probability. On
> my side (daily report) they will be ok.

Where's that? ;) Only asking because I dont think you make it avaiable
publicly.

> Who should I notify/where what
> to verify for builders on classpath.org?

The only public instance that I know of is mjw's testers. You can see
what the testers do here:

http://icedtea.classpath.org/hg/buildbot/file/05e41e1c037b/icedtea/master.cfg#l157

>>> diff -r 1088b2dffe49 tests/report-styles/jreport.xsl
>>> --- a/tests/report-styles/jreport.xsl    Tue May 22 12:08:17 2012 +0200
>>> +++ b/tests/report-styles/jreport.xsl    Tue May 22 14:32:43 2012 +0200
>>> @@ -53,11 +53,17 @@
>>>       <xsl:value-of select="/testsuite/date"/>
>>>       <br/>
>>>       <h2>Result: (<xsl:value-of
>>> select="round(sum(/testsuite/testcase/@time))"/>s)</h2>
>>> +<h4>In brackets are KnownToFail values if any</h4>
>>
>> Might be nicer if we just leave this description out and display
>> "expected:" or "known:" in the brackets.
> 
> hmhm.. Actually I don know... It it will not be nice to have
> 
> total 10 (from which 8 known to fail)
> passed 5 (but 4 are know to fail)
> failed 3 (and 3 known to fail)
> ignored 2 (one known to fail)
> 
> To much words... But can be more descriptive. What do you think?
> I left my original one in patch.

Okay, fair enough.

>>> @@ -65,6 +71,11 @@
>>>           <div class="cell1">passed:</div>
>>>           <div class="cell2">
>>>             <xsl:value-of select="/testsuite/stats/summary/passed"/>
>>> +<xsl:choose>
>>> +<xsl:when test="/testsuite/stats/summary/passed/@knownToFail!=0">
>>> +             (<xsl:value-of
>>> select="/testsuite/stats/summary/passed/@knownToFail"/>)
>>> +</xsl:when>
>>> +</xsl:choose>
>>
>> I am having trouble parsing this. Are these tests that are known to fail
>> that passed? Should we be flagging this more importantly?
>>
> This should not happen, but it can happe:). Eg some patch fill fix some
> secondary issue unwillingly, so author will be noticed.
> Or programmer just forget that some more tests corresponding to his
> patch have this annotation.
> 
> explained?

Okay, but surely we should be flagging this as important so the
developer can remove the @KnownToFail annotation?

>>> diff -r 1088b2dffe49
>>> tests/netx/jnlp_testsengine/net/sourceforge/jnlp/annotations/KnownToFail.java
>>>
>>> --- /dev/null    Thu Jan 01 00:00:00 1970 +0000
>>> +++
>>> b/tests/netx/jnlp_testsengine/net/sourceforge/jnlp/annotations/KnownToFail.java   
>>> Tue May 22 14:32:43 2012 +0200
>>
>>> +/**
>>> + * This annotation should be declared for each test which is
>>> representing an issue
>>> + * where icedtea-web is not doing as correctly as expected, and so
>>> the test, by its failure,
>>> + * is showing this behaviour.
>>> + * If the issue is fixed, annotation should be removed.
>>> + *
>>> + */
>>
>> How about:
>>
>> """
>> This annotation marks a test as a known failure (as opposed to a
>> regression). A test that is a known failure will not hold of a release,
                                                             ^^
That "of" should have been "off". Sorry; my mistake.

> diff -r 1088b2dffe49 tests/junit-runner/LessVerboseTextListener.java
> --- a/tests/junit-runner/LessVerboseTextListener.java	Tue May 22 12:08:17 2012 +0200
> +++ b/tests/junit-runner/LessVerboseTextListener.java	Wed May 23 16:41:21 2012 +0200

> @@ -45,7 +60,56 @@
>          int passed = result.getRunCount() - result.getFailureCount() - result.getIgnoreCount();
>          int failed = result.getFailureCount();
>          int ignored = result.getIgnoreCount();
> -        writer.println("Test results: passed: " + passed + "; failed: " + failed + "; ignored: " + ignored);
> +        writer.println("Test known to fail ("+totalK2F+"): passed: " + passedK2F + "; failed: " + failedK2F + "; ignored: " + ignoredK2F);
> +        writer.println("Test results ("+result.getRunCount()+"): passed: " + passed + "; failed: " + failed + "; ignored: " + ignored);
> +    }

Please leave the original line ("Test results: passed:"..) unchanged
(unless you are going to combine the two lines).

Otherwise, this looks fine to me.

Cheers,
Omair



More information about the distro-pkg-dev mailing list