[fyi][icedtea-web]Refactoring of reproducers as agreed in April

Omair Majid omajid at redhat.com
Thu Jun 28 09:18:03 PDT 2012


On 06/28/2012 11:44 AM, Jiri Vanek wrote:
> On 06/28/2012 05:20 PM, Omair Majid wrote:
>>> # HG changeset patch
>>> # User Jiri Vanek<jvanek at redhat.com>
>>> # Date 1340880424 -7200
>>> # Node ID aea1cafcefbfab4e69995854ffcecd78a674d751
>>> # Parent  31f78e1476a0af93ace536580fa4f54b37e5f2e7
>>> Makefile.am  adapted to recent (three changesets) refactoring.
>>>
>>> diff --git a/Makefile.am b/Makefile.am
>>> --- a/Makefile.am
>>> +++ b/Makefile.am
>>> @@ -17,9 +17,12 @@
>>>   export JUNIT_RUNNER_DIR=$(TESTS_DIR)/junit-runner
>>>   export JUNIT_RUNNER_SRCDIR=$(TESTS_SRCDIR)/junit-runner
>>>
>>> -export JNLP_TESTS_ENGINE_SRCDIR=$(TESTS_SRCDIR)/netx/jnlp_testsengine
>>> -export JNLP_TESTS_SRCDIR=$(TESTS_SRCDIR)/jnlp_tests
>>> -export JNLP_TESTS_ENGINE_DIR=$(TESTS_DIR)/netx/jnlp_testsengine
>>> +
>>> +export JNLP_TESTS_ENGINE_SRCDIR=$(TESTS_SRCDIR)/test-extensions
>>> +export
>>> JNLP_TESTS_ENGINE_TESTS_SRCDIR=$(TESTS_SRCDIR)/test-extensions-tests
>>> +export JNLP_TESTS_SRCDIR=$(TESTS_SRCDIR)/reproducers
>>> +export JNLP_TESTS_ENGINE_DIR=$(TESTS_DIR)/jnlp_testsengine
>>> +export
>>> JNLP_TESTS_ENGINE_TESTS_DIR=$(TESTS_DIR)/netx/jnlp_testsengine_tests
>>>   export JNLP_TESTS_SERVER_DEPLOYDIR=$(TESTS_DIR)/jnlp_test_server
>>>   export JNLP_TESTS_DIR=$(TESTS_DIR)/jnlp_tests
>>>   export PRIVATE_KEYSTORE_NAME=teststore.ks
>>
>> Could you rename the variable so they are more accurate? Something like
>> JNLP_TESTS_ENGINE_SRCDIR ->  TEST_EXTENSIONS_SRCDIR makes more sense to
> 
> sure. Give sens.. Will do tomorrow morning as new changeset (will send
> to review together with those already existing 5) for you.
> 
>> me. Also, can you update the build dir names to match the src dir names?
> 
> Please no - my tools are depending on those directory names. I really
> donot want to change them, because sudenly there will be necessary two
> tryes to find files to compare - one in old name and second in new.

Perhaps you can add symlinks for compatiblity? I would really like to
see consistent names. Otherwise it will be harder for developer to do
the mapping from source dir names to build dir names.

>>> @@ -634,8 +637,24 @@
>>>       mkdir -p stamps&&  \
>>>       touch $@
>>>
>>> +netx-dist-tests-tests-source-files.txt:
>>
>> s/netx-dist-tests-tests-source-files/test-extensions-sources-files/
> 1
>>
>>> +    find $(JNLP_TESTS_ENGINE_TESTS_SRCDIR) -name '*.java' | sort>  $@
>>> +
>>> +stamps/netx-dist-tests-tests-compile.stamp: stamps/netx.stamp \
> 2
> 
>>
>> A clearer name for this stamp too, please.
> 
> hmh.. they are not so bad.
> 
> If you insists, then first will become test-extensions-tests-sources-files.
> 
> Th rest is derived from top level target:

We might want to consider better names for top-level targets too (and
leave older targets for compatibility)

> run-netx-dist-tests =>
> netx-dist-tests-source-files
> netx-dist-tests-tests-source-files
> 
> But if you insists I will chnage  both netx-dist-tests-source-files and
> netx-dist-tests-tests-source-files to something more reliable to new names.
> 

Please do.

>>
>>> + stamps/junit-jnlp-dist-dirs netx-dist-tests-tests-source-files.txt \
>>> + stamps/netx-dist-tests-compile.stamp
>>> +    mkdir -p $(JNLP_TESTS_ENGINE_TESTS_DIR);
>>> +    $(BOOT_DIR)/bin/javac $(IT_JAVACFLAGS) \
>>> +     -d $(JNLP_TESTS_ENGINE_TESTS_DIR) \
>>> +     -classpath
>>> $(JUNIT_JAR):$(NETX_DIR)/lib/classes.jar:$(JNLP_TESTS_ENGINE_DIR) \
>>
>> The tests for the test-extensions depend on netx to build? Seems rather
>> weird.
> 
> I will check this before tomorrow morning new-set-of-patches

Thanks!

>>
>>> +     @netx-dist-tests-tests-source-files.txt&&  \
>>> +    mkdir -p stamps&&  \
>>> +    touch $@
>>
>> I dont think any of these ";" or "&&  \" are needed. It should be fine if
>> each command was executed in a new shell.
>>
>> Everything else looks fine for now.
> Than you very much :)

No problem.

Omair





More information about the distro-pkg-dev mailing list