Applet's in browser, slow loading, remote and (in some bright future) graphical testing and some minor improvements (was Re: Icedtea-web splashscreen implementation)

Pavel Tisnovsky ptisnovs at redhat.com
Mon Mar 12 07:13:54 PDT 2012


> done in "runtime".
> 
>> - -//- splitArray (it needs JavaDoc
> definitely. Sorry for forgot it.
> too, contains double ";;" on one line etc.)
> damn. YY - fixed
>>    I think it could be simplified to use one loop only and two index
>> variables
>>    (we can talk about this personally)
> Can it? Make your shot! O:) Btw  - I have *one* loop, tehn second O:)
> for copyying of aray (As I'm not friend of copyarray method :( ) and
> *one* index, but yes, the header of method is not nice. But it was still
> fighting with me:-/ Make your shot!

Version w/o your loved System.arraycopy :-) I personally dislike these two
ifs on the beginning because I think it should be done differently without
the need to multiply and modulo:

    public static byte[][] splitArray(byte[] input, int pieces) {
        int rest = input.length;
        int rowLength = rest / pieces;
        if (rest % pieces > 0) rowLength++;
        if (pieces * rowLength >= rest + rowLength) pieces--;
        int i = 0, j = 0;
        byte[][] array = new byte[pieces][];
        array[0] = new byte[rowLength];
        for (byte b : input) {
            if (i >= rowLength) {
                i = 0;
                array[++j] = new byte[Math.min(rowLength, rest)];
            }
            array[j][i++] = b;
            rest--;
        }
        return array;
    }




More information about the distro-pkg-dev mailing list