[icedtea-web] resurrection of (output)console?

Jiri Vanek jvanek at redhat.com
Tue Nov 5 05:09:46 PST 2013


On 11/04/2013 11:20 PM, Omair Majid wrote:
> Hi,
>
> Comments in-line below.

Hello, thanx for them!

You did not commented 1.4 version - this was not  new version of patch which obsolated the 1.4 but completely separate patch.
>
> * Jiri Vanek<jvanek at redhat.com>  [2013-11-04 10:10]:
>> On 11/04/2013 12:29 PM, Jiri Vanek wrote:
>
>>> Imho "debug" should have nothing to do with "redirecting" also it
>>> was used wrongly, and made consoel even less usefull...
>
> One of the main motivation behind the console is to see stdout/stderr of
> applets (especially on platforms where stdout/stderr is not visible by
> default).

Yes, and exactly this it was never doing.

I'm fully aware if it, and I hope this patch i leading to it. Also I have an intention to add also runtime plugin messages and also c++ init messages before java side is even initialised (the initial Console impl have not even thought about it)

>
>> +++ b/NEWS	Mon Nov 04 16:08:16 2013 +0100
>
>> +* Enabled and enhanced javaconsole for plugin and javaws
>
> A slightly clearer to read version might be:
>
> "A console for debugging plugin and javaws"

I'm happy to do so
>
>> +++ b/netx/net/sourceforge/jnlp/config/DeploymentConfiguration.java	Mon Nov 04 16:08:16 2013 +0100
>
>> @@ -64,14 +64,11 @@
>
>>       public static final String CONSOLE_HIDE = "HIDE";
>>       public static final String CONSOLE_SHOW = "SHOW";
>>       public static final String CONSOLE_DISABLE = "DISABLE";
>> +    public static final String CONSOLE_SHOW_PLUGIN = "SHOW_PLUGIN_ONLY";
>> +    public static final String CONSOLE_SHOW_JAVAWS = "SHOW_JAVAWS_ONLY";
>
> FWIW, only SHOW, HIDE and DISABLE are documented for Oracle's
> proprietary implementation. If you are going to add more, they should
> be documented somewhere.

probably in wiki in 1.5 release notes, so it have time. However I think they are quite self documenting
>
>> @@ -160,6 +157,8 @@
>>        * Console
>>        */
>>       public static final String KEY_CONSOLE_STARTUP_MODE = "deployment.console.startup.mode";
>> +    //search for values above CONSOLE_*
>
> Please put the comment before the variable. Adding it to the javadoc
> should be fine too.
happy to full-fill your wish :)
>
>> +++ b/netx/net/sourceforge/jnlp/resources/Messages.properties	Mon Nov 04 16:08:16 2013 +0100
>
>> +DPShowPluginOnly=Show on startup, only for plugin
>
> "Show on plugin startup"
>
>> +DPShowJavawsOnly=Show on startup, only for javaws
>
> "Show on javaws startup"
>
>> +DPJavaConsoleDisabledHint=Sorry, java console is disabled, turn it to hide, or show in itw-settings
>
> Sorry, I am having trouble understanding this description. Maybe
> something like this:
>
> "Java console is disabled. Use itweb-settings to configure it to show on startup."
   nearly - Java console is disabled. Use itweb-settings to configure it out of disabled to any show or hide value.

- as hide is ok here to (console showed on demand)
>
>> +SPLASHmainL2 = You can get some more information by checking console, or even turn debug on in itw-settings
>
> "Additional information may be available in the console or if debugging
> is enabled"
  - nearly - Additional information may be available in the console or logs. Even more information can be provided if debugging is enabled

Sure! Sorry for my English:(
>
>> +++ b/netx/net/sourceforge/jnlp/runtime/JNLPRuntime.java	Mon Nov 04 16:08:16 2013 +0100
>
>> @@ -196,6 +193,16 @@
>
>> +            if (DeploymentConfiguration.CONSOLE_SHOW.equals(
>> +                    JNLPRuntime.getConfiguration().getProperty(DeploymentConfiguration.KEY_CONSOLE_STARTUP_MODE))
>> +                    || (DeploymentConfiguration.CONSOLE_SHOW_PLUGIN.equals(
>> +                    JNLPRuntime.getConfiguration().getProperty(DeploymentConfiguration.KEY_CONSOLE_STARTUP_MODE))
>> +&&  !isApplication)
>> +                    || (DeploymentConfiguration.CONSOLE_SHOW_JAVAWS.equals(
>> +                    JNLPRuntime.getConfiguration().getProperty(DeploymentConfiguration.KEY_CONSOLE_STARTUP_MODE))
>> +&&  isApplication)) {
>> +                JavaConsole.getConsole().showConsoleLater();
>> +            }
>
> Is there a better place to put this code?

I doubt. I had it in several palces at at hte end I finished here. The creation of console is depending on JNLPruntime done, especially on config.load. On the other side it should eb enabled as soon as possible. And I would like to avoid more blind copies of config - http://icedtea.classpath.org/hg/icedtea-web/file/a817bb6d12a6/netx/net/sourceforge/jnlp/util/logging/LogConfig.java#l67
Personally I would like  to have it "nowhere" and initialize it lazily. However it is not(?) possible while config is handled as wrong as it is. (or maybe whole JNLPruntime). It is something between singelton x static x normal code, and all this "if initialized" stuff really annoys me.
On the other side its maybe better then JNLPruntime.getRuntime(){if runtime == null runtime=newe Runtime(); return runtime} and same for config :))

However I moved the "if" logic to console and added headless condition.

>
>> +++ b/netx/net/sourceforge/jnlp/splashscreen/parts/JEditorPaneBasedExceptionDialog.java	Mon Nov 04 16:08:16 2013 +0100
>
>> @@ -166,9 +171,9 @@
>>           GroupLayout jPanel2Layout = new GroupLayout(topPanel);
>>           topPanel.setLayout(jPanel2Layout);
>>           jPanel2Layout.setHorizontalGroup(
>> -                jPanel2Layout.createParallelGroup(GroupLayout.Alignment.LEADING).addGroup(jPanel2Layout.createSequentialGroup().addContainerGap().addComponent(closeButton).addContainerGap().addComponent(aboutButton).addPreferredGap(LayoutStyle.ComponentPlacement.RELATED, 314, Short.MAX_VALUE).addComponent(closeAndCopyButton).addContainerGap()));
>> +                jPanel2Layout.createParallelGroup(GroupLayout.Alignment.LEADING).addGroup(jPanel2Layout.createSequentialGroup().addContainerGap().addComponent(closeButton).addContainerGap().addComponent(aboutButton).addContainerGap().addComponent(consoleButton).addPreferredGap(LayoutStyle.ComponentPlacement.RELATED, 314, Short.MAX_VALUE).addComponent(closeAndCopyButton).addContainerGap()));
>>           jPanel2Layout.setVerticalGroup(
>> -                jPanel2Layout.createParallelGroup(GroupLayout.Alignment.LEADING).addGroup(GroupLayout.Alignment.TRAILING, jPanel2Layout.createSequentialGroup().addContainerGap(24, Short.MAX_VALUE).addGroup(jPanel2Layout.createParallelGroup(GroupLayout.Alignment.BASELINE).addComponent(closeButton).addComponent(aboutButton).addComponent(closeAndCopyButton)).addContainerGap()));
>> +                jPanel2Layout.createParallelGroup(GroupLayout.Alignment.LEADING).addGroup(GroupLayout.Alignment.TRAILING, jPanel2Layout.createSequentialGroup().addContainerGap(24, Short.MAX_VALUE).addGroup(jPanel2Layout.createParallelGroup(GroupLayout.Alignment.BASELINE).addComponent(closeButton).addComponent(aboutButton).addComponent(consoleButton).addComponent(closeAndCopyButton)).addContainerGap()));
>>
>>           exceptionLabel.setFont(new java.awt.Font("Dialog", 1, 18)); // NOI18N
>>           exceptionLabel.setHorizontalAlignment(SwingConstants.CENTER);
>
> This is really, really hard to read. The convention, when writing trees
> like this, is to do something like (code from another project):
>
>          GroupLayout groupLayout = new GroupLayout(getContentPane());
>          groupLayout.setHorizontalGroup(
>              groupLayout.createParallelGroup(Alignment.TRAILING)
>                  .addGroup(groupLayout.createSequentialGroup()
>                      .addContainerGap()
>                      .addGroup(groupLayout.createParallelGroup(Alignment.TRAILING)
>                          .addComponent(closeButton, GroupLayout.PREFERRED_SIZE, 92, GroupLayout.PREFERRED_SIZE)
>                          .addComponent(panel, GroupLayout.DEFAULT_SIZE, 424, Short.MAX_VALUE))
>                      .addContainerGap())
>          );
>
>
> Basically, use indentation to 'show' the tree. Parallel branches go in
> the same indentation level.

sure
>
>> +++ b/netx/net/sourceforge/jnlp/util/logging/JavaConsole.java	Mon Nov 04 16:08:16 2013 +0100
>
> There's lots of non-localized strings in this file. I am pointing them
> out now, but feel free to localize them in a separate patch.
>
>> +   Copyright (C) 2009  Red Hat
>
> Please update the copyright.
>
done

>> + * A simple Java console for IcedTeaPlugin
>
> Please update the comment.

A simple Java console for IcedTeaPlugin and JavaWS (? is thsi what you wonted? there wos not so much chnages as it appeared)
>
>> +public class JavaConsole {
>
>> +     * Initialize the console
>> +     */
>> +    private void initialize() {
>> +
>> +        try {
>> +            UIManager.setLookAndFeel(UIManager.getSystemLookAndFeelClassName());
>> +        } catch (Exception e) {
>> +            OutputController.getLogger().log(OutputController.Level.ERROR_ALL,e);
>> +        }
>
> This seems like the wrong place to set the look and feel. Isn't the look
> and feel set up once in Launcher?

You are whipping me for somebody else code :) This was hg move JavaConsole.
Tbh i do not know:( Anyway I'm going to work on console appearance so I would let this for that time.
>
>> +        final String logDir = JNLPRuntime.getConfiguration().getProperty(DeploymentConfiguration.KEY_USER_LOG_DIR);
>
> Unused variable?
correct, my apologise
>
> Lots of missing localizations:
>

Again... whipped for somebody else work :( But better do it now then later
/me had no intention to i18nthis :(
/me ashamed for laziness

..at the end..done
>> +        consoleWindow = new JDialog((JFrame)null, "Java Console");
>
>> +        JButton gcButton = new JButton("Run GC");
>
>> +                OutputController.getLogger().log(OutputController.Level.MESSAGE_ALL, "Performing Garbage Collection....");
>
>> +                OutputController.getLogger().log(OutputController.Level.MESSAGE_ALL, "Done");
>
>> +        JButton finalizersButton = new JButton("Run Finalizers");
>
>> +                OutputController.getLogger().log(OutputController.Level.MESSAGE_ALL, "Running finalization....");
>
>> +                OutputController.getLogger().log(OutputController.Level.MESSAGE_ALL, "Done");
>
>> +        JButton memoryButton = new JButton("Memory Info");
>
>> +        JButton systemPropertiesButton = new JButton("System Properties");
>
>> +        JButton classloadersButton = new JButton("Classloaders");
>
>> +        JButton threadListButton = new JButton("Thread List");
>
>> +        JButton closeButton = new JButton("Close");
>
>> +    public void showConsole() {
>> +        showConsole(false);
>> +    }
>> +
>> +     public void showConsole(boolean b) {
>> +        consoleWindow.setModal(b);
>> +        consoleWindow.setVisible(true);
>> +    }
>> +
>> +    public void hideConsole() {
>> +        consoleWindow.setModal(false);
>> +        consoleWindow.setVisible(false);
>> +    }
>> +
>> +     public void showConsoleLater() {
>> +        showConsoleLater(false);
>> +    }
>> +      public void showConsoleLater(final boolean b) {
>> +        SwingUtilities.invokeLater(new Runnable() {
>> +            public void run() {
>> +                JavaConsole.getConsole().showConsole(b);
>> +            }
>> +        });
>> +    }
>> +
>> +    public void hideConsoleLater() {
>> +        SwingUtilities.invokeLater(new Runnable() {
>> +            public void run() {
>> +                JavaConsole.getConsole().hideConsole();
>> +            }
>> +        });
>> +    }
>
> This seems overly complex. Can you make it non-modal? And just
> use showConsole() and hideConsole() ?

no:(

The reason Why I added modality possibility, was because of JEditorPaneBasedExceptionDialog.
The JEditorPaneBasedExceptionDialog is (have to be)  already modal, so if the jconsole is NOT modal, then it is shown UNDER the JEditorPaneBasedExceptionDialog. And is not accessible.

>
>> +++ b/netx/net/sourceforge/jnlp/util/logging/OutputController.java	Mon Nov 04 16:08:16 2013 +0100
>>           }
>> +        if (LogConfig.getLogConfig().isLogToConsole()) {
>> +            if (Level.isOutput(s)){
>> +            JavaConsole.getConsole().logOutput(message);
>> +            }
>> +            if (Level.isError(s)){
>> +            JavaConsole.getConsole().logError(message);
>> +            }
>> +        }
>
> Cool, but this will not capture an applet's stdout/stderr, will it?

not yet. But it never did.

But it *must* and is on todo:)

My current in mind design:
  - before pipes are ready and jvm initialised (already existing switch in plugin) all "in future by pipes to console messages" are written to tmp, to  600 file. (or to two stdout/err)
  - once jvm is initialised this file is closed, and all plugin messages are "logged" through pipe to javaside. Javaside is then correctly logging this messages as all others
  - console, on show, load the "tmp, to  600 file(s)". before the actuall lines, maybe to separate textarea(s) wth explanation that it is pre-java started output
  - the "tmp, to  600 file(s)." is deleted on plugin's shutdown

Two consequences
  - if this will work, then it may cut the decission issues about the system and file logs
  - if it will not work, then, on the other hand, the logging decision can help here
    - the console can use "already existing plugin log(s) - whatever it will be
>
> Thanks,
> Omair

Thanx on my side (as always :) )

   J.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: resurectedConsoleForHead2
Url: http://mail.openjdk.java.net/pipermail/distro-pkg-dev/attachments/20131105/6ee2ccf3/resurectedConsoleForHead2-0001.ksh 


More information about the distro-pkg-dev mailing list