[rfc][icedtea-web] synced headers between PLUGIN_ERROR, PLUGIN_DEBUG and java
Omair Majid
omajid at redhat.com
Thu Oct 31 11:10:52 PDT 2013
Hi Jiri,
* Jiri Vanek <jvanek at redhat.com> [2013-10-31 13:12]:
> diff -r 14a8ee171687 netx/net/sourceforge/jnlp/util/logging/OutputController.java
> --- a/netx/net/sourceforge/jnlp/util/logging/OutputController.java Wed Oct 30 10:36:03 2013 +0100
> +++ b/netx/net/sourceforge/jnlp/util/logging/OutputController.java Thu Oct 31 17:57:00 2013 +0100
> @@ -346,6 +346,7 @@
> if (stack != null) {
> sb.append('[').append(getCallerClass(stack)).append(']');
> }
> + sb.append(" NETX Thread# ").append(Integer.toHexString(((Object)Thread.currentThread()).hashCode())).append(", name ").append(Thread.currentThread().getName());
Some nits, here.
You probably don't need to cast Thread.currentThread() to Object,
hashCode is defined on all types.
The output of this will be NETX Thread# 0x<ThreadID>, name <Thread Name>.
Maybe it would be more readable as:
NETX Thread 0x<Thread Id> [<Thread Name>]
Please consider appropriate line-wrapping. Something like this is a
little easier to read:
sb.append(" NETX Thread#")
.append(Integer.toHexString(((Object)Thread.currentThread()).hashCode()))
.append(", name ")
.append(Thread.currentThread.getName());
I am far from an expert on C++, so take the next bit of advice with a
grain of salt.
> +++ b/plugin/icedteanp/IcedTeaPluginUtils.h Thu Oct 31 17:57:00 2013 +0100
> +#define CREATE_HEADER(f) \
Please document f. Is it a FILE*, a char*, or a fd?
> + do \
> + { \
> + char s[200]; \
> + time_t t = time(NULL); \
> + struct tm * p = localtime(&t); \
If you are expecting to have multiple threads run this code, please use
_r variants of function calls (localtime_r). These non-_r variants use
static data and are not thread safe.
Cheers,
Omair
More information about the distro-pkg-dev
mailing list