Oracle Java 8 problems due to TLS policy change

Andrew Hughes gnu.andrew at
Fri Apr 11 18:19:00 UTC 2014

----- Original Message -----
> Ping?
> On Fri, Apr 4, 2014 at 11:03 AM, helpcrypto helpcrypto <helpcrypto at
> > wrote:
> > According to
> >
> > Java 8 now uses TLS1.1 and TLS1.2 (both enabled by default on
> > Control Panel).
> >
> > This seems to be causing an error in our applet loading. Problem seems
> > solved if both unchecked. Funny thing is our server only supports TLS1.0.
> >
> > Is icedtea8 following the same TLS policy? (switching to TLS1.1 and TLS1.2)
> > If so, i should check if the same error appears.
> >

I'm not sure what you're referring to here. There is no control panel in
IcedTea/OpenJDK 6, 7 or 8. I seem to remember TLS 1.2 support being added
as part of 7 (it was one of the reasons for the addition of an explicit
ECC provider).

If this is related to deployment tools, then you need to be looking at IcedTea-Web,
which is separate for any individual JDK.

> > BTW: I have noticed latest Ubuntu pkg doesnt work anymore with our
> > there must be a JSObject regression in the last...year? I'll
> > let you know after tests.

I guess you'd need to consult the packagers about this to start with and then
they can forward the bug upstream if necessary. I don't know the individual
versions etc. packaged by Ubuntu, or about any local changes they make.

> >
> > Thanks and good day!
> >

Andrew :)

Free Java Software Engineer
Red Hat, Inc. (

PGP Key: 248BDC07 (
Fingerprint = EC5A 1F5E C0AD 1D15 8F1F  8F91 3B96 A578 248B DC07

More information about the distro-pkg-dev mailing list