[rfc][icedtea-web] get rid of custom@@ markup for documentation

Jie Kang jkang at redhat.com
Tue Oct 14 18:47:13 UTC 2014



----- Original Message -----
> This patch is replacing all usages by @BOLD...@ by html equivalents <b> or
> </B>  (case does not
> meter, nor do spaces inside)
> 
> I don't have better idea how to get rid of it:(
> 
> 
> There was one more note to this - to include some escaping - I'm not going to
> implement it  until it
> is needed, but if it will be needed, then I would go y this same way - have
> html escaping in
> properties, and get rid of it in ReplacingFormatter.
> 
> The docs looks same with this patch, as they looked before.
> 
> 
> Thoughts?


Hello

Yay unit tests! Nice :)

The change isn't that big compared to @BOLD...@ but I don't have any suggestions atm as to what can be done instead.

It looks good except for a few minor nits below:

+            @Override
+            public String wrapParagraph(String s) {
+                throw new UnsupportedOperationException("Not supported yet."); //To change body of generated methods, choose Tools | Templates.
+            }

Can these unrelated comments be removed?

+    @Test
+    public void mixedCases1() {
+        String s = tr.process("aaa <B> bbb </b> ccc");
+        Assert.assertEquals("aaa OPEN bbb CLOSE ccc", s);
+    }
+    @Test
+    public void mixedSpace2() {
+        String s = tr.process("aaa <b> bbb </B> ccc");
+        Assert.assertEquals("aaa OPEN bbb CLOSE ccc", s);
+    }

I think second test should be called mixedCases2.


+     @Test
+    public void uppercaseSpaces() {
+        String s = tr.process("aaa <   B  > bbb <  /     B > ccc");
+        Assert.assertEquals("aaa OPEN bbb CLOSE ccc", s);
+    }

Personally, I think you should force the tags to be correctly written as <b> (or <B>) and </b> unless there is a situation where a <b> does not work compared to < b >. 

Finally, before pushing, can you double-check all the whitespaces.

+    @Override
+    public String process(String s) {
+        //the texts in properties are already using html markup
+        return s;
+    }
+
+    

For example, there are now 3 lines between process(...) and the next function. Should just be one I think.


Regards,

> 
> J.
> 

-- 

Jie Kang


More information about the distro-pkg-dev mailing list