[rfc][icedtea-web] chromum-browser renamed to chromium

Jie Kang jkang at redhat.com
Mon Oct 20 14:57:09 UTC 2014



----- Original Message -----
> The reproducers tests are no longer recognizing chromium, due changed name of
> its main binary.
> 
> This patch is fixing it.

Hello,


Looks okay. I am curious, why you did you use the static constructor instead of placing the if-statement inside the case-statement?

E.g:

Why not:

case chromiumBrowser:
   return (new File(LinuxBrowser.DEFAULT_BIN_PATH, chromium-browser).exists()) ? "chromium-browser" : "chromium";


And if you want you can move the conditional to a separate function:

E.g:


case chromiumBrowser:
   return LinuxBrowserPathExists() ? "chromium-browser" : "chromium";

private boolean LinuxBrowserPathExists() {
   return new File(LinuxBrowser.DEFAULT_BIN_PATH, alt).exists()
}



Regards,

> 
>    J.
> 

-- 

Jie Kang


More information about the distro-pkg-dev mailing list